Comment calculer le nb de jrs entre 2 dates avec une condition [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
jeudi 25 septembre 2014
Statut
Membre
Dernière intervention
26 septembre 2014
-
 Lulu -
Bonjour,

J'ai un tableau avec des demandes de travaux.

B1 contient la date à laquelle la demande de travaux est lancée au technicien.
B2 contient la date à laquelle les travaux sont terminés.

Je voudrais connaitre la formule a appliquer de manière à ce que :
B3 indique le nombre de jours entre B1 et B2 inclus si B2 est rempli
B3 indique le nombre de jours entre B1 et aujourd'hui inclus si B2 est vide

Comme c'est un tableau avec plusieurs centaines d'entrées je ne peux pas changer les formules à chaque fois que la condition "B2 comporte une date" remplie

Une solution ?

Merci d'avance !

4 réponses

Messages postés
11960
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
2 avril 2020
1 754
Bonjour

formule en B3 :
=si(B2="";aujourdhui()-B1+1;b2-b1+1)

Cdlmnt
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 74946 internautes nous ont dit merci ce mois-ci

Messages postés
1270
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
512
Bonjour,

Pour le cas ou B1 est vide

=SI(B1="";"";SI(B2="";AUJOURDHUI()-B1;B2-B1))

Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 74946 internautes nous ont dit merci ce mois-ci

Messages postés
15
Date d'inscription
mardi 23 septembre 2014
Statut
Membre
Dernière intervention
7 janvier 2016

Bonjour,
Je pense peut être avoir trouvé une solution:
-en B3 tu rentre =SI(B2;B2-B1;A2-B1)
-Par contre il faut que tu créer une autre case avec la formule de la date d'aujourd'hui (moi je les mise en A1 qui est =AUJOURDHUI() )
-et voila tu rentre en B1 ta date de début et en B2 tu laisse vide ou tu met la date que tu souhaites.
Traduction de la formule : si quelque chose en B2 faire B2-B1 sinon faire A2-B1.
Merci Prim44. Ça très bien fonctionné
Messages postés
2
Date d'inscription
jeudi 25 septembre 2014
Statut
Membre
Dernière intervention
26 septembre 2014

Bonjour,

Merci beaucoup ! J'ai utilisé la première formule proposée par via55, ça fonctionne ! Super !
Voila une journée qui commence bien :)