Totaliser une valeur conditionnée d'une autre feuille [Résolu/Fermé]

Signaler
Messages postés
90
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
1 novembre 2019
-
JL00700
Messages postés
90
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
1 novembre 2019
-
Bonjour,

Excel 2013 - WINDOXS 8.1

J'ai 12 feuilles (Janvier, Février, etc). sur chacune d'elle, j'ai une colonne (M4:M400) comprenant différentes références. Dans une autre colonne (V4:V400) se trouvent des valeurs.
J'ai créé une nouvelle feuille que j'ai nommé "Formules" comportant 12 colonnes (Janvier...) et sur les lignes, mes références.
Cette feuille va me servir de synthèse pour établir des statistiques.
Je souhaite écrire une formule qui totalise les valeurs pour chaque réf.
Ex : si ma colonne est Janvier alors aller sur feuille Janvier, rechercher la ref (XXXXXX) en colonne (M4:M400) et totaliser la valeur en colonne (V4:V400).
Je pense qu'il faut utiliser les fonctions SOMME.SI, ESTERREUR et INDIRECT mais je ne sait pas du tout comment faire.
Je reste à votre disposition pour tout complément si nécessaire.
Merci par avance de votre attention et de vos conseils avisés.
Cordialement.

3 réponses

Messages postés
11591
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
23 janvier 2020
1 608
Bonsoir

En supposant dan la feuille Récaputalive les noms des feuilles (Janvier ..; ) en B1, C1 etc et en colonne A à partir de A2 les références :
formule en B2 =SOMME.SI(INDIRECT(B$1&!M4:M400");$A2;INDIRECT(B$1&!V4:V400") en respectant bien les $ aux bons endroits puis étirer la formule à droite puis en bas

Cdlmnt
Messages postés
90
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
1 novembre 2019

Bonjour,
Merci de votre réponse via55
Cela ne fonctionne pas mais c'est probablement de ma faute, j'ai à coup sûr mal exprimé le contexte.
Peut-être avec ceci cela vous aidera.
Effectivement, le nom des feuilles se trouve bien en B1, C1, etc...
Les références en colonne M s'étalent de la ligne 4 à 400 mais à chaque ligne j'ai une ref différente et une valeur en colonne V.
Exemple :

Ligne colonne M colonne V
4 400 18.32
5 1700 20.43
6 100 33.89
7 2000 58.14
8 300 66.42
9 1700 77.56
etc... jusque ligne 400

Mais ref colonne M peuvent prendre la valeur 100 - 200 - 300 - 400 etc jusque 2100

Je souhaite donc obtenir la somme des valeurs colonne V pour chacune des Ref.
Je vous remercie par avance de votre attention.
Cordialement
via55
Messages postés
11591
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
23 janvier 2020
1 608
Si ça ne fonctionne pas c'est peut être de la mienne, je m'aperçois qu'en tapant j'ai oublié des guillemets dans la formule avant chaque ! :
SOMME.SI(INDIRECT(B$1& "!M4:M400");$A2;INDIRECT(B$1& "!V4:V400")
Dis moi si ça va mieux sur ton fichier

Cdlmnt
Messages postés
90
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
1 novembre 2019

G E N I A L !!!! via55
Je te remercie de ton aimable collaboration.
Je continue mon développement qui prend de la gu.... et tu y a contribué.
Amicalement.