Menu

Somme de valeur en fonction d'une colonne et d'une ligne [Résolu/Fermé]

Messages postés
2
Date d'inscription
mardi 29 juillet 2014
Statut
Membre
Dernière intervention
29 juillet 2014
-
Bonjour,

Suite à une recherche infructueuse sur le site, je me permets de vous solliciter pour de l'aide sur le sujet suivant :

J'ai un tableau "tableau 1" que je voudrais synthétiser et afficher sous la forme du tableau 2 (voir pj).


Est-il donc possible d'utiliser une formule (sans macro) de somme et de recherche pour récupérer une valeur en fonction du titre d'une colonne et des informations présentes dans les lignes?

J'espère avoir été assez clair... Je vous remercie d'avance pour vos réponses.

Cdlt,
Afficher la suite 

3 réponses

Messages postés
8918
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
15 mai 2019
1944
0
Merci
Bonjour

Un exemple
http://cjoint.com/?3GDnHevWQu9

Cdlmnt
Messages postés
10601
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
15 mai 2019
1404
0
Merci
Bonjour

1) nommer les plages :
A2:A20 noms
B2:B20 mois
C2:C20 HS_Semaine (il faut le _ car les noms de plage n'acceptent pas les espaces
D2:D20 HS_Weekend
E2_E20 Astreinte

2) Remplacer dans tableau 2 tous les HS Semaine par HS_Semaine et HS Weekend par HS_Weekend (car la formule viendra ici lire le nom de la plage de recherche)

3) en C23 mettre la formule :

=SOMME.SI.ENS(INDIRECT($B23);noms;$A23;mois;c$22) en respectant bien les emplacements des $

Étirer la formule sur les lignes et les colonnes

ou si version Excel avant 2007
=SOMMEPROD((noms=$A23)*(mois=C$22)*INDIRECT($B23))

Cdlmnt


Messages postés
2
Date d'inscription
mardi 29 juillet 2014
Statut
Membre
Dernière intervention
29 juillet 2014
0
Merci
Re-bonjour,

Vos solutions fonctinnement à merveille !!

Merci pour la rapidité et la qualité de vos réponses. Vous m'enlevez une épine du pied.

Une bonne continuation à vous.

Cdlt,