Afficher date et heure si données [Résolu/Fermé]

Signaler
-
 nemi -
Bonjour,

J'ai une feuille excel dans laquelle je voudrais que lorsque l'on inscrit des données dans la colonne A, l'heure et la date d'entrée s'affiche automatiquement dans la colonne B sur la même ligne. Par exemple si on entre "portable" en A1 la date et l'heure à laquelle la personne a tapé cette donnée s'affiche dans la cellule B1.
J'ai essayé de trouver un truc avec SI et Maintenant mais sans grand succès ....

Merci d'avance !!


2 réponses

Messages postés
941
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
36
C'est uniquement possible avec des macros.

Si vous voulez je vous dis comment faire.
Messages postés
4278
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1 119
Bonjour
Essaie avec cette formule

=SI(A1="";"";MAINTENANT())
Cordialement
Merci déjà pour votre reponse !

Oui j'aurais besoin que la cellule garde l'heure du moment de la modification !
via55
Messages postés
11781
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 février 2020
1 670
Bonjour

Dans ce cas il faut passer par une macro

Alt F11 pour ouvrir l'éditeur
Selectionner dans l'arborescence la feuille concernée
Copier et coller la macro suivante :

Private Sub Worksheet_Change(ByVal Target As Range)
ActiveSheet.Cells(Target.Row, 2) = Now
End Sub

Cdlmnt
skk201
Messages postés
941
Date d'inscription
jeudi 11 septembre 2008
Statut
Membre
Dernière intervention
16 octobre 2016
36
@via55 Il veut que ça soit lors de la modification de la colonne A :) faut le intersect

Private Sub Worksheet_Change(ByVal Target As Range) 
If Not Intersect(Target, Range("A:A")) Is Nothing Then
ActiveSheet.Cells(Target.Row, 2) = Now 
End If
End Sub 


@ Nemi
Est-ce que ça ne serai pas plus intéressant que la date de dernière modification apparaisse comme un commentaire de la cellule en question ?
via55
Messages postés
11781
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
21 février 2020
1 670
@skk201 Tu as parfaitement raison, j'avais zappé l'histoire de la colonne A