Moyenne de ligne non egale a zero [Résolu/Fermé]

Signaler
Messages postés
105
Date d'inscription
jeudi 1 avril 2010
Statut
Membre
Dernière intervention
2 juin 2014
-
ludo.di
Messages postés
105
Date d'inscription
jeudi 1 avril 2010
Statut
Membre
Dernière intervention
2 juin 2014
-
Bonjour,

je souhaite avoir dans un tableau une moyenne des cellules qui ne sont pas égales à zéro.

pour l'instant ma formule (qui ne fonctionne pas) et comme ceci:

=MOYENNE(P4:P186)/NB.SI(P4:P186;"<>0")

les cellules P sont le résultat d'autre cellules

où est mon erreur svp ?


1 réponse

Messages postés
25003
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
4 avril 2020
5 142
Bonjour
votre formule est assez curieuse! vous divisez une moyenne par un nombre de valeurs??
ne serait ce pas plutôt:
=SOMME(P4:P186)/NB.SI(P4:P186;"<>0")

ou alors plus simplement:
=MOYENNE.SI(P4:P186;"<>0";P4:P186)

crdlmnt
ludo.di
Messages postés
105
Date d'inscription
jeudi 1 avril 2010
Statut
Membre
Dernière intervention
2 juin 2014
7
merci, je ne connaissais pas le Moyenne.si, c'est parfait !