Formule excel avec 2 conditions [Fermé]

Signaler
-
 letraule -
Bonjour !
Je n'arrive pas à trouver une formule excel.
Voici l'exemple :
Sexe Age
1 F 48
2 H 80
3 F 76
4 F 77
5 F 46
6 H 50
7 F 52
8 H 81

Il me faudrait le nombre de femmes ayant moins de 60 ans.

Merci de votre aide!

6 réponses

Messages postés
23360
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
9 avril 2020
6 028
Bonsoir,


Bon, faut compter les femmes ou les hommes ??? faut savoir... ;-)

Donc :
de A1 à A8 : H ou F
de B1 à B8 : l'age

Tu peux le faire avec sommeprod()

en B10: =SOMMEPROD((A1:A8="F")*1;(B1:B8>=40)*1;(B1:B8<70)*1) =>> 3 (nbre de femmes d'au moins 40 ans et de moins de 70 ans)
en fait tu calcules des matrices de résultats de test {vrai;faux;faux;vrai...} et tu les multiplies par 1 ce qui fait qu'excel les transforme en {1;0;0;1;....} donc tu peux faire leur somme (celle du sommeprod).
Tu peux mettre autant de tests que tu veux

eric
30
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 81316 internautes nous ont dit merci ce mois-ci

Messages postés
23913
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 777
Salut,

la fonction nb.si ne marche que sur un seul critère.

Il te faut donc créer un nouvelle colonne avec un test à deux conditions (=SI(ET(B1="F";C1<60);"1";"0")) qui affichera 1 quand les conditions sont réunies, et 0 sinon. Ensuite, tu pourras faire un nb.si (=NB.SI(D1:D8;1)) dans cette colonne.
Merci pour ta réponse, ceci m'a éclairé.
Mais mon problème est encore plus compliqué !

En fait, je dois créer des classes d'âge par sexe. Je dois calculer :
- le nombre d'hommes ayant entre 50 et 60 ans,
- le nombre d'hommes ayant entre 61 et 70 ans etc...
Messages postés
23913
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 777
Soit tu crées autant de pseudo-colonnes que tu as de critères, mais c'est pas clean (notamment si tes demandes évoluent), soit tu fais un lien depuis une base ACCESS, et tu pourras ensuite lancer des requêtes comme il te plaira...
>
Messages postés
23913
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020

Je n'ai pas ACCESS, donc j'ai créé autant de colonnes que j'avais de critères.

C'est vrai que c'est un peu fastidieux, mais ca marche. C'est l'essentiel !!!

Merci beaucoup pour tes explications.
Merci cette formule a deux conditions m'a bien aidé sur un autre probleme.
Messages postés
23913
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
13 janvier 2020
2 777
Salut,

tu les trouves où tes autres lettres ?

Parce que récupérer le premier caractère d'une cellule, on sait faire avec = GAUCHE(A1;1), mais trouver 'axi', je ne sais pas...
Messages postés
36
Date d'inscription
mardi 1 avril 2008
Statut
Membre
Dernière intervention
25 avril 2008

bonjour,

En fait le T c'est pour Taxi
et j'ai aussi V pour VSL et A pour ambulance

Donc une fois que j'ai la première lettre je voudrais pouvoir automatiquement l'associer au nom auquel il correspond

Merci de ton aide
Messages postés
62
Date d'inscription
jeudi 5 février 2009
Statut
Membre
Dernière intervention
4 octobre 2009
>
Messages postés
36
Date d'inscription
mardi 1 avril 2008
Statut
Membre
Dernière intervention
25 avril 2008

La formule ci-dessous doit marcher , si toutefois j'ai bien compris....
=SI(GAUCHE(D6;1)="T";"Taxi";SI(GAUCHE(D6;1)="V";"VSL";SI(GAUCHE(D6;1)="A";"Ambulance")))
à+
Bonjour,

JE SUIS EN TRAIN DE MONTER UN TABLEAU EXCEL SOMMES TOUTE ASSEZ IDENTIQUE

des effectifs et leus competences comme ci dessous :

1 NOM PRÉNOM Groupe compétence 1 competence 2
aaaa aaaa 1 x
bbb bbbb 2 x x
ccc ccc 3 x
ddd ddd 4 x
eee eee 5 x x
fff fff 6 x

je cherche la formule qui me permet une fois un groupe filtré (expl groupe 1)
de calculer le nombre d'effectif ayant la competence selectionnée
puis avoir les données dans un recap comme ci dessous dans chaque groupe
ceci n'est qu'un exemple
mon tableau contient un effectif de 320 personnels.


competence 1 competence 2
TOTAL GROUPE 1
TOTAL GROUPE 2
TOTAL GROUPE 3
TOTAL GROUPE 4
TOTAL GROUPE 5
TOTAL GROUPE 6
TOTAL GROUPE 6
TOTAL EFFECTIFS

d'avance merci pour votre aide my
bonjour,

je réalise un tableau sous excel et je veux récupérer la premirère lettre d'un code.

En effet, je veux attribuer à la cellule de la meme ligne le nom mais en entier.

Par exemple en A1 j'ai T543 et je veux automatiquement mettre en A2 Taxi.

J'espère que c'est possible sans les macros par une formule comme recherche V.

Merci

Cordialement
La réponse est 3. (Les personnes 1,5 et 7)