Menu

Calculs des heures dans des créneaux horaires [Résolu/Fermé]

Messages postés
10
Date d'inscription
samedi 26 avril 2008
Statut
Membre
Dernière intervention
27 janvier 2014
- - Dernière réponse : Dom28130
Messages postés
10
Date d'inscription
samedi 26 avril 2008
Statut
Membre
Dernière intervention
27 janvier 2014
- 27 janv. 2014 à 05:42
Bonjour à tous,

Je tourne en rond sur ce sujet depuis pas mal de temps.

Je dois mettre en place une organisation, en personnel, qui prenne compte du temps de disponibilité de matériel.
Pour ceci j'ai défini 3 créneaux horaires :
- 6h00..14h00
- 14h00..22h00
- 22h00..6h00


J'ai aussi comme données les heures d'arrivée du matériel et les heures de restitution.

En parcourant les divers forums j'ai pu faire les calculs du temps total de dispo, remplir certaines cases de mes plages horaires mais rien trouvé qui remplisse l'ensemble de mes plages horaires et surtout la période 22h / 6h.

Si quelqu'un peut m'aider..
Dans l'attente.

Cdt
            
Afficher la suite 

12 réponses

Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
444
0
Merci
Bonjour,

En A2, l'heure de début
En B2, l'heure de fin
En C2, la durée avec la formule =MOD((B2-A2);1)

A+
Messages postés
10
Date d'inscription
samedi 26 avril 2008
Statut
Membre
Dernière intervention
27 janvier 2014
0
Merci
Bonjour Gyrus,

Je ne sais pas si tu as eu mon mail de réponse alors je te renvoie via le site mais je ne sais pas comment joindre mon fichier.

cette formule a été essayé et elle fonctionne nickel quand je calcule le temps total de dispo : colonne Temps Dispo en F
Ci-joint mon fichier Excel.

Merci de ton aide.
Cdt
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
444
0
Merci
Non, je n'ai pas reçu ton mail de réponse ... ton fichier non plus d'ailleurs :)

Pour t'aider à joindre un fichier
http://www.commentcamarche.net/faq/29493-utiliser-cjoint#q=cjoint&cur=1&url=%2F

A+
Messages postés
10
Date d'inscription
samedi 26 avril 2008
Statut
Membre
Dernière intervention
27 janvier 2014
0
Merci
Ok je comprends mieux ton silence.

Ci-joint mon fichier Excel
http://cjoint.com/?DAAkZBfwdY0

Cdt
Messages postés
3341
Date d'inscription
samedi 20 juillet 2013
Statut
Membre
Dernière intervention
9 décembre 2016
444
0
Merci
Je comprends mieux ton problème et je n'ai pas la réponse.
Je passe la main à un autre intervenant qui se sera déjà frotté à ce type de formule qui couvre une période supérieure à une journée .

Si un éclair de génie vient me foudroyer entre temps, je te ferai signe.
Désolé de ne pas pouvoir t'aider d'avantage.

A+
Messages postés
22775
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 juillet 2019
5554
0
Merci
Bonjour à tous,

et surtout la période 22h / 6h.
Sans se prendre la tête je dirais en J7 :
=F7-H7-I7

eric
Messages postés
10
Date d'inscription
samedi 26 avril 2008
Statut
Membre
Dernière intervention
27 janvier 2014
0
Merci
Bonsoir Eric,

Tout d'abord merci de t'intéresser à mon problème.
Mais ta proposition ne fonctionne pas, elle donne le total de temps dispo mais ne donne pas le temps dispo PAR TRANCHE HORAIRE.

Ci-joint mon fichier avec ta proposition.
J'ai mis en rouge l'illustration de ce je dis plus haut.

http://cjoint.com/?DAAth1ueB5R


Dans l'attente d'une solution.
Cdt
eriiic
Messages postés
22775
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 juillet 2019
5554 -
Mais ta proposition ne fonctionne pas, elle donne le total de temps dispo
Pas du tout.
Elle donne le temps total - tranche 1 - tranche 2, que tu as déjà calculés.
C'est à dire, si je ne m'abuse : tranche 3

eric
Messages postés
10
Date d'inscription
samedi 26 avril 2008
Statut
Membre
Dernière intervention
27 janvier 2014
0
Merci
Le temps total je l'ai dans la colonne Temps Dispo c'est à dire colonne F, et c'est ce que reprend ta formule :=F7-H7-I7

Place manuellement le matériel dans les tranches horaires selon les heures dispo et heures rest et tu verras que cela ne correspond pas au résultat de formule.

Pour exemple sir je prends :
Matériel 2461
Heure dispo 19:00
Heure rest 06:00
Je dois avoir dans la tranche 2 ==> 3h
Je dois avoir dans la tranche 3 ==> 8h
Le total correspond bien au total de 11h dispo

J'espère avoir été assez clair.
Cdt
eriiic
Messages postés
22775
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
17 juillet 2019
5554 -
Re,

Tu es très clair.
Il n'en demeure pas moins que Tranche3 (qui t'embête) = Total - Tranche1 - Tranche2.
Je ne peux pas être plus clair non plus.

JvDo (en-dessous) annonce que tes formules pour Tranche1 et 2 sont erronées, ceci explique l'erreur que tu vois.

eric
Messages postés
1935
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
11 juillet 2019
749
0
Merci
Bonsoir à tous,

En fait, tu as un problème avec tes formules pour les tranches 1 et 2.
Sinon, la réponse d'eriiic t'aurait satisfait.

Tu peux essayer cette formule matricielle, à mettre en H7, valable pour n'importe quelle tranche :
=SOMMEPROD((SI($E7>$D7;--(LIGNE($1:$1440)>=ARRONDI(1440*$D7;0))*(LIGNE($1:$1440)<1440*$E7);1-(LIGNE($1:$1440)<ARRONDI(1440*$D7;0))*(LIGNE($1:$1440)>=ARRONDI(1440*$E7;0))))*(SI(H$6>H$5;(LIGNE($1:$1440)>=ARRONDI(1440*H$5;0))*(LIGNE($1:$1440)<ARRONDI(1440*H$6;0));1-(LIGNE($1:$1440)<ARRONDI(1440*H$5;0))*(LIGNE($1:$1440)>=ARRONDI(1440*H$6;0)))))/1440
tu valides par CTRL+MAJ+ENTER
tu recopies sur H7:J7.

cordialement
0
Merci
Bonsoir à tous,
Ma proposition pour les colonnes 1 & 2, aux colonnes H et I près:
=SI(OU(D7>=H$5;E7<=H$6);MIN(E7;H$6)-MAX(D7;H$5);0)

Je continue à chercher pour la colonne 3; en fait je l'ai scinder en 2 tranches 22h-24h et 0h-6h mais je cale sur les interventions qui sont à cheval sur plusieurs tranches et évidemment sur les heures de début qui sont supérieures aux heures de fin.
Bonne soirée
JvDo
Messages postés
1935
Date d'inscription
mercredi 27 juillet 2005
Statut
Membre
Dernière intervention
11 juillet 2019
749 -
Bonsoir tessel75

je viens de tester vite fait et il me semble qu'à partir de la ligne 19 il n'y a plus rien.

cdlt
Exact! Je regarde ce qui se passe. Mais j'ai pu voir aussi que le fichier original est bourré de macros et de mises en forme, je me demande s'il n'y a pas des interférences avec des conditionnelles.
Non! J'ai trouvé. La formule de calcul hormis la condition SI ...,
= SI ... MIN(E19;I$6)-MAX(D19;I$5)
Mais l'heure de fin de travaux est 6h, donc le calcul strict rend des heures négatives. C'est bien là la principale difficulté.
Salutation et merci
0
Merci
Réponse au sujet:

Formule pour la tranche 6-14 Colonne H Ligne 7:
=SI(OU(D7>=H$5;E7<=H$6);MIN(E7;H$6)-MAX(D7;H$5);0) + SI(ET(D7<H$5;E7>H$6);H$6-H$5;0)

Formule pour la tranche 14-22 Colonne I Ligne 7:
=SI(D7>E7;I$6-D7;SI(OU(D7>=I$5;E7<=I$6);MIN(E7;I$6)-MAX(D7;I$5);0)+ SI(ET(D7<I$5;E7>I$6);I$6-I$5;0))

Comme j'avais dit précédemment j'ai scindé la tranche 22-6 en 2 tranches, 22h-24h et 0h-6h
Formule pour la tranche 22-24 Colonne J Ligne 7:
=SI(D7>E7;J$6-D7;SI(OU(D7>=J$5;E7<=J$6);MIN(E7;J$6)-MAX(D7;J$5);0)+ SI(ET(D7<J$5;E7>J$6);J$6-J$5;0))
et Formule pour la tranche 0-6 Colonne K Ligne 7:
=SI(D7>E7;MIN(E7;K$6);SI(D7<K$6;MIN(E7;K$6)-MAX(D7;K$5);0)+SI(ET(D7>I$5;D7<J$6;E7>K$6;E7>J$5);K$6-K$5;0))

Il peut juste advenir qq erreurs lorsque le travaux de nuit durent très longtemps depuis avant 14h jusqu'à après 6h.
Bonne suite.
Messages postés
10
Date d'inscription
samedi 26 avril 2008
Statut
Membre
Dernière intervention
27 janvier 2014
0
Merci
Bonjour à tous,

Tout d'abord désolé pour ma réponse tardive mais le sommeil m'a rattrapé..
La formule de JvDo fonctionne NICKEL !!!!!!!!!!! je n'ai pas testé les autres propositions mais MERCIIIIIIIIIIIIIIIIIIIIIIIIIIII !!!!!!!!!!!!!!!!!!

Je vais pouvoir avancer sur le dossier.

Je n'ai fait que du copier/coller mais j'essaierai de la comprendre plus tard.

Encore Merci, c'est génial. Je commençais à baisser les bras.

Bonne continuation.
Bien Cordialement.