Formule de calcul de somme si dans autre cellule il y a "OUI" [Résolu/Fermé]

- - Dernière réponse :  Dilisk - 8 janv. 2014 à 13:58
Bonjour,

Je souhaite savoir comment déclencher le calcul d'une formule de la plage (A1:A8), par exemple, seulement si dans ma cellule B4 j'ai le mot "OUI"

Quelqu'un a t'il la solution ?

MErci pour vos réponses.

Afficher la suite 

3 réponses

Messages postés
23073
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
5755
0
Merci
Bonjour,

essaie avec :
=si(B4="oui";somme(A1:A8);"")

eric
0
Merci
Bonjour Eric

Merci Eric pour ta réponse.

Je me suis mal exprimé ce que je cherche a faire est:

Moi je veux calculer un solde des valeurs du colonne B qui prend en compte que les montant que j'aurai dis "OUI" en colonne A

Je veux que le montant soit pris en compte que si je note note "OUI".

Exemple:

Colonne A Colonne B
OUI 2
NON 2
OUI 2
NON 2


Total 4 <<<< Quelle est la formule qui trouve ce résultat ?




C'est plus clair comme explication ?
Vaucluse
Messages postés
24669
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
4886 -
Bonjour
=SOMME.SI(A:A;"OUI";B:B)
mais contrairement à votre premier message, le OUI est maintenant en A et le montant en B
Mon ami Eric avait peu de chance de tomber juste du premier coup!
crdlmnt
Merci pour cette réponse Vaucluse !! C EST EXACTEMENT CELA.

Et si par exemple je veux prendre en compte dans mon total de colonne B un solde initial (Genre +10) je mets cette formule :

=SOMME.SI(F5:F11;"OUI";10-G32:E11]) ?

Exemple:

Solde Initial: 10

Colonne A Colonne B
1: OUI 2
2: NON 2
3: OUI 2
4: NON 2


Total: 6

( En gros je veux trouver le résultat de 10 - Ligne 1 et ligne 3, En notant en colone A "OUI")
Vaucluse
Messages postés
24669
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
4886 -
Voit pas ce que G2 vient faire la dedans? toujours aussi clair, !
SOMME.SI exige que les eux champs aient al même hauteur et ce que vous proposez ne correspond à rien:
Par ailleurs vous parlez d'un total B avec une formule qui parle de R et G ????
si on prend votre demande à la lettre et pour rester dans la formule des colonnes AZ et B:
si vous avez un départ de solde en C1:

=SOMME.SI(A:A;"OUI";B:B)+C1

sinon essayez d'pêtre beaucoup beaucoup plus clair!!
Parfait Vaucluse merci pour l'aide ^^
Messages postés
23073
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
15 novembre 2019
5755
0
Merci
Plus clair, oui. Surtout plus exact.

=SOMME.SI(A2:A5;"oui";B2:B5)

eric