Menu

Comparer deux cellule texte et extraire une donnée d'une colonne [Fermé]

Messages postés
2
Date d'inscription
vendredi 27 décembre 2013
Statut
Membre
Dernière intervention
30 décembre 2013
- - Dernière réponse : Vaucluse
Messages postés
24210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
- 30 déc. 2013 à 10:51
Bonjour à tous, J'ai un petit soucis pour effectuer une tache sous excel.
En effet je ne parviens pas à effectuer la chose suivante :
J'ai une cellule texte en A2 = me5047, j'ai aussi une cellule texte en I2 = me5047 et une colonne J2 avec 50 (un prix).
Je souhaiterais dans une autre cellule, comparer SI A2(texte)=I2(texte) alors ma cellule = J2 mais je ne parviens pas à comparer deux cellules texte...
Merci d'avance pour votre aide précieuse.
CDLT
Afficher la suite 

2 réponses

Meilleure réponse
Messages postés
24210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
4681
2
Merci
Bonjour

si la formule:

=SI(A2=I2;J2;"")

ne fonctionne pas c'est que vos textes ne sont pas identiques en A2 et J2.
Pour vérifier cela:
copier A2, coller sur I2 et voyez si votre formule renvoie bien J2

Sinon, c'est peut être aussi que votre question manque de précision.

crdlmnt

Errare humanum est, perseverare diabolicum

Dire « Merci » 2

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 54737 internautes nous ont dit merci ce mois-ci

Messages postés
2
Date d'inscription
vendredi 27 décembre 2013
Statut
Membre
Dernière intervention
30 décembre 2013
0
Merci
C'est OK. Merci bien pour votre réponse.
Celle ci m'emmène une deuxième question.
En effet, j'ai deux colonnes de texte A et C (des références produit) et une colonne D avec des prix associés aux références de la colonne C. Les références produits ne sont pas forcément sur les mêmes lignes en A et C car dans la colonne C certaines références apparaissent alors quelles n'étaient pas dans la colonne A.
Est-il possible via une RECHERCHEV ou autre en colonne B, de mettre les prix correspondant aux références de la colonne C qui sont identiques à la colonne A et NA quand la référence n'existait pas en A?
Suis je clair?
D'avance merci pour votre aide
CDLT
Vaucluse
Messages postés
24210
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 juillet 2019
4681 -
Je ne suis pas du tout sur d'avoir compris, essayez à tout hasard avec:

en B2, à tirer sur la hauteur:

=SI(NB.SI(A:A;C2)=0;"NA";D2)
cette formule renvoie la valeur de D en ligne avec C si C existe n'importe


crdlmnt