Somme si avec 2 critères [Résolu/Fermé]

- - Dernière réponse : Vaucluse
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
- 18 déc. 2013 à 12:36
Bonjour,

Je dois trouver un nombre de points au cumul d'une semaine mais à une date précise.
Dans mon tableau, j'ai des points qui sont calculés pour chaque jour de l'année.

Exemple:

La semaine N°3 va du 13/01 au 19/01/14.
Quand j'ouvre le fichier le 16/01/14, je souhaite qu'il fasse l'addition des points de la semaine N°3, mais que du 13 au 16/01/14.


Avec Somme Si, je peux lui donner comme critère la semaine en cours, mais je ne peux pas affiner ma demande en lui précisant de ne comptabiliser que jusqu'à une certaine date dans cette même semaine et pas au-delà...


Merci pour votre aide...


Afficher la suite 

1 réponse

Messages postés
11242
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
24 octobre 2019
1466
0
Merci
Bonsoir

Si version Excel au moins 2007 tu peux utiliser SOMME.SI.ENS avec plusieurs critères
ex : = SOMME.SI.ENS(plage à sommer;plage des dates;">12/01/14";plage des dates;"<17/01/14")

Cdlmnt
Bjr Via55,

Merci pour votre réponse.

Seul bémol, c'est que le 2ème critère (la date) ne fonctionne pas.

Je m'explique,

Voici la fonction:
=SOMME.SI.ENS('feuille1'!FS12:FS2000;'feuille1'!J12:J2000;C7;'feuille1'!K12:K2000;"<A1")
1er critère: que le N° de la semaine dans la colonne J, soit le même que celui dans la cellule C7 (ok fonctionne)
2ème critère: que la date dans colonne K, soit < à la date de la cellule A1 (ne fonctionne pas).
Pour info, la date dans A1 est issue de la fonction Aujourd'hui().
Je dois préserver cette fonction Aujourd'hui pour déterminer le critère N°2.
Comment faire pour lui faire reconnaître cette date ?

(Excel 2010)

Merci d'avance...
Vaucluse
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4843 -
Bonjour
pour que le critère inférieur à la date en A1 fonctionne, écrire:

"<"&A1
avec le signe & entre le signe entre guillemets et l'adresse
ou
"<"&AUJOURDHUI()

Crdlmnt
Bonjour Vaucluse,

Hé bien, je n'ai qu'un mot...Merci !

Crdlnt
Vaucluse
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4843 -
Ça suffira largement... bonne route