Formule [Résolu/Fermé]

Messages postés
154
Date d'inscription
mercredi 26 janvier 2011
Statut
Membre
Dernière intervention
24 décembre 2018
- - Dernière réponse : via55
Messages postés
10921
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2019
- 26 août 2013 à 22:27
Bonjour,
Pour calculer la moyenne générale des 3 trimestres, j'utilise la formule MOYENNE. Mais cette formule affiche ERREUR (#DIV/0) quand les cellules contenant les valeurs des 3 trim sont vides, Alors j'ai besoin d'une autre formule (si cela est possible) qui donne la valeur 0 au-lieu (#DIV/0) sans donner 0 a chaque trim,
Merci pour vos aides.
Cordialement
Afficher la suite 

1 réponse

Messages postés
10921
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2019
1358
0
Merci
Bonjour

=SIERREUR(MOYENNE(A1:A3);0)

ou si tu préferes que rien ne soit affiché au lieu du 0, tu remplaces le 0 par "" dans la formule

Cdlmnt
ccm81
Messages postés
9050
Date d'inscription
lundi 18 octobre 2010
Statut
Membre
Dernière intervention
5 août 2019
1605 -
Bonjour via55

Je ne comprend pas bien ta formule et excel 2003 non plus
j'aurais plutôt mis
=SI(ESTERREUR(MOYENNE(A1:A3));0;MOYENNE(A1:A3))

cordialement
via55
Messages postés
10921
Date d'inscription
mercredi 16 janvier 2013
Statut
Membre
Dernière intervention
7 août 2019
1358 -
Bonjour ccm81

Tu as raison la fonction SIERREUR n'est valide que depuis excel 2007 elle remplace avantageusement en plus court celle que tu proposes mais la tienne a l'avantage d'être comprise par toutes les versions excel

Cdlmnt