[Excel]recherche à partir de 2 critères [Résolu/Fermé]

Messages postés
10
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
3 février 2018
- - Dernière réponse : breza9
Messages postés
10
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
3 février 2018
- 30 juil. 2013 à 12:08
Bonjour,

Je voudrais faire une recherche à partir de 2 critères et en afficher le résultat ce situant dans une 3e colonne.

Un exemple très simple devrait être plus explicite:

Un tableau m'indique en A, la ville de Départ, en B la ville d'arrivé et en C la distance entre ces 2 villes.

Maintenant dans un second tableau je définis une ville de départ et d'arriver, et je dois avoir la distance correspondante.

Existe t'il une formule le permettant? La fonction recherche ne prend qu'un seul critère malheureusement et j'ai pas réussi à en combiner 2 via un ET logique. Peut être le Sommeprod ou index que je maitrise mal...
Éventuellement je peux essayer de passer par de la macro mais je suis pas sur que c'est nécessaire

Merci à toute les personnes prenant le temps de m'aider.

breza9
[Excel 2010]
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
5375
Date d'inscription
lundi 16 avril 2012
Statut
Contributeur
Dernière intervention
5 décembre 2019
358
1
Merci
Bonjour

Sur la feuil1 la source ajouter une colonne ou vous concaténer les 2 noms de villes

En A1 mettre cette formule =B1&" "&C1

et sur la feuil2 la recherche mettre cette formule sur la ligne des villes à chercher

En C1 =RECHERCHEV(A1&" "&B1;Feuil1!A1:D20;4)

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64136 internautes nous ont dit merci ce mois-ci

Messages postés
1265
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
140
0
Merci
Bonjour,
Dans ton tableau, une ville départ ne correspond pas à une seule ville d'arrivée ?

Si c'est le cas, une distance entre deux villes correspond à une seule ville départ, et tu n'as besoin que d'un critère de recherche (ville départ).
Et une distance entre deux villes correspond aussi à une seule ville d'arrivée, donc là aussi, besoin que d'un seul critère ;-)
Messages postés
10
Date d'inscription
lundi 29 juillet 2013
Statut
Membre
Dernière intervention
3 février 2018
0
Merci
Merci pour vos réponses.

Non une ville de départ peut correspondre à plusieurs villes d'arriver.

Ta solution fonctionne parfaitement PHILOU.

Merci beaucoup