Menu

Tableau croisé dynamique - absence de certaines données [Résolu/Fermé]

- - Dernière réponse :  RaymboX - 7 avril 2016 à 18:33
Bonjour,

J'utilise Excel 2010. A partir d'un tableau de données, j'ai créé un tableau croisé dynamique (TCD) pour analyser le grand nombre de données du tableau.
Je sélectionne bien l'ensemble du tableau contenant les données à analyser, et le TCD est bien créé comme je le souhaite. Pour faire court, il s'agit de faire le bilan du nombre d'heures effectuées par groupe, en totalisant le nombre d'heures données par chaque professeur pour ce groupe.
Mes données de base sont donc le numéro du groupe, le professeur, et le nombre d'heures que le professeur a effectué.

Toutefois, certaines données n'apparaissent pas dans le TCD, alors qu'elles sont bien comprises dans le tableau de données.

Par exemple, il manque certains groupes dans le TCD. Dans d'autres cas, un groupe apparaît bien, mais un des professeurs lié à ce groupe n'apparaît pas.

J'ai testé toutes les options dans les paramètres de champ ou dans les options du TCD, mais je n'y arrive pas.
J'ai aussi essayé de ne mettre dans mon TCD que le champ "professeurs", et c'est le même problème, certains n'apparaissent pas dans la liste.

Quelqu'un a une idée ?

Merci d'avance!
Afficher la suite 

2 réponses

Meilleure réponse
9
Merci
J’ai vécu la même situation et même en sélectionnant le tableau, ça ne fonctionnait pas. J’ai ensuite trouvé la solution et la raison. La raison : J’ai créé un tableau et ajouter des colonnes par la suite (plus précisément, j’ai inséré des colonnes dans mon tableau). Du coup, même si visuellement ses colonnes étaient dans mon tableau, ceux-ci n’en faisaient pas parti. Solution : Cliquer n’importe où dans le tableau, appuyer sur l’onglet Création et redimensionner le tableau. Sélectionner toute les colonnes et rangé du tableau. Un fois fait, actualiser le tableau croisé dynamique et voila.

Dire « Merci » 9

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 39340 internautes nous ont dit merci ce mois-ci

2
Merci
Re,

J'ai trouvé la source du problème, et réussi à corriger ça.
En fait, le problème venait du fait que mon tableau de données était un tableau avec mise en forme automatique. Quand je crée un TCD, ça sélectionne bien automatiquement l'ensemble du tableau, mais certaines données sont manquantes comme je l'ai décrit.
Pour avoir l'ensemble des données, il faut sélectionner manuellement le tableau et les entêtes de colonnes lorsqu'on crée le TCD. Et ça marche!

Par contre, pas d'explication pour savoir pourquoi ça bugue avec un tableau automatique...
eriiic
Messages postés
22736
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 mai 2019
5478 -
ok, je met en résolu pour toi (en haut vers ton titre, pour la prochaine fois)
eric