Non-application des modifications de php.ini [Fermé]

Messages postés
1
Date d'inscription
lundi 6 mai 2013
Statut
Membre
Dernière intervention
6 mai 2013
-
Bonjour à tous.
Je suis conscient que ce problème n'est pas exactement de programmation, mais de configuration de php.

Actuellement, mon serveur est un centOS.

En ce moment, je modifie la configuration /etc/php.ini pour correspondre aux besoins de mon application de conception de dossiers (avec plein de fichiers intégrés et tout ça).
Ce qui veut dire que je comptais modifier ces éléments :
memory_limit
post_max_size
upload_max_filesize
session.gc_maxlifetime

Quand je modifie, je redémarre bien entendu le service associé: httpd
(service httpd restart)

Le truc est que le serveur n'applique pas mes nouvelles valeurs...
Alors il charge bien le fichier (c'est ce qui est affirmé par phpinfo())
Mais les valeurs données sont les valeurs par défaut, pas les miennes

les valeurs changées sont:
memory_limit=1024M
post_max_size=1024M
upload_max_filesize=1024M (j'ai du gros zip à transmettre)
session.gc_maxlifetime=36000 (un dossier, ça met du temps à être conçu)

J'ai essayé avec des valeurs plus petites (le double de la base), mais ça ne marche pas quand même.

J'imagine que j'ai modifié une valeur que j'aurai pas dû (et dont j'ai oublié l'intitulé) car l'informatique ne doit pas être si ésotérique.

Merci beaucoup d'avance.

Angius.

PS: le dsi est en vacances.
Afficher la suite 

1 réponse

Messages postés
137
Date d'inscription
lundi 22 mars 2010
Statut
Contributeur
Dernière intervention
3 septembre 2014
29
0
Merci
Salut.
Je ne connais pas vraiment centOS, mais sous Ubuntu, il y a deux fichiers php.ini. Un pour le CLI, l'autre pour apache.

Dans ubuntu, le php.ini à modifier pour apache est dans /etc/php5/apache2/php.ini.

Pour centOS, je ne sais pas si le fichier est placé au même endroit, mais je pense que le principe reste le même.