Pb formule SI [Résolu/Fermé]

Signaler
Messages postés
87
Date d'inscription
mardi 10 juillet 2012
Statut
Membre
Dernière intervention
16 février 2017
-
leozero
Messages postés
87
Date d'inscription
mardi 10 juillet 2012
Statut
Membre
Dernière intervention
16 février 2017
-
Bonjour,

j'ai un petit souci : j'aimerais que

si la cellule C1<50 alors la cellule C3=2
si la cellule 50<C1<100 alors la cellule C3=4
si la cellule C1>100 alors la cellule C3=6

j'ai tapé soit :

=SI(C1="";"";SI(C1<50;2;SI(OU(C1>50;C1<100);4;si(C1>100;6;""))))

soit

=SI(C1="";"";SI(C1<50;2;SI(OU(C1>50;C1<100);4;6)))

soit

=SI(C1="";"";SI(C1<50;2;SI(50<C1<100;4;6)))

mais la formule ne fonctionne pas lorsque C1>100... ca affiche toujours 4 dans la C3. ou alors, C3 n'affiche plus rien lorsque la valeur de C2 est comprise entre 50 et 100.

Pouvez-vous m'aider ?

Merci !!

4 réponses

Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1161
Bonjour,

il faut remplacer le OU par ET.
En effet, si vous tapez 124 avec votre raisonnement 124>50 ou 124<100 est vrai et retourna 4.

Si tu remplace par un ET, 124<50 ET 124<100 est faux, donc il passera à la condition suivante (124>100), et retournera donc 6.

Cordialement.
Messages postés
24738
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
11 décembre 2019
4922
Bonjour
=SI(C1="";"";SI(C1<50;2;SI(C1<100;4;6)))
Ça devrait suffire
Remarque pour info:
votre 1° formule ne pouvait pas fonctionner quand C1=50 ou C1 =100 et ce n'est pas OU qu'il fallait utiliser mais ET
Si vous voulez inclure la limite dans la condition écrivez <= au lieu de <

crdlmnt
Messages postés
87
Date d'inscription
mardi 10 juillet 2012
Statut
Membre
Dernière intervention
16 février 2017

Merci à vous deux !!

en effet, c'était bien le OU qui bloquait. avec le ET ca fonctionne.

Merci !!

bon aprem !