Menu

Astuces EXCEL [Résolu/Fermé]

Messages postés
119
Date d'inscription
samedi 6 octobre 2012
Statut
Membre
Dernière intervention
25 juillet 2013
-
Bonjour,

Je travaille sur 21 années de chroniques de pluies:
- Colonne A : 1/01/1990; 2/01/1990, ... jusqu'au 31/12/2010 avec les années bissextiles
- Colonne L : hauteurs des pluies journalières

1) Je cherche à réaliser créer les colonne O:

- Colonne O : moyenne de tous les 1/01 de 1990 à 2010; moyenne de tous les 2/01 de 1990 à 2010; etc

Sélectionner manuellement 21 jours pour les moyenner c'est assez pénible (mais faisable ...). Il n'y aurait pas un autre moyen qui me permettrait d'aller plus vite ? Parc que si je sélectionne tous les 1/01, et que j'en fais la moyenne, puis que je "tire" la cellule sur les 364 jours restant je suis embêtée:
Je dois prendre en compte les années bissextiles ... et du coup à pour le 29/02 je dois selectionner manuellement les 4 ou 5 occurences et recommencer a selectionner les 21 1/03 puis "tirer" jusqu'en décembre.

bref je cherche juste des petits raccourcis ...

2) Sachant que je travaille sur des collonnes dont le nombre de lignes varie entre 365 et 7670 lignes (-_-), comment je pourrais :
- selectioner une colonne entière sans faire glisser la souris pendant ... longtemps :)
- appliquer une formule à toute la colonne (au lieu de tirer la cellule jusqu'en bas)


Merci à tous :) et si vous avez d'autres petites astuces n'hésitez pas (^_^)
Bonne journée !!

laurie

Afficher la suite 

3 réponses

Messages postés
1854
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
1 avril 2019
511
0
Merci
Bonjour,

voici une proposition de formule pour calculer automatiquement la moyenne :
a mettre dans la cellule O2 (je suppose qu'il y a une ligne d'entête)

=SOMMEPROD((JOUR(A$2:A$7670)=JOUR(A2))*(MOIS(A$2:A$7670)=MOIS(A2))*(L$2:L$7670))/SOMMEPROD((JOUR(A$2:A$7670)=JOUR(A2))*(MOIS(A$2:A$7670)=MOIS(A2))*1)


Et étirer sur les 365 lignes.

Remarque la première année bissextile étant 1992 il faut copier la formule en face du 29/02/1992 pour avoir la moyenne à cette date.

Alors pour étirer automatiquement jusqu'a la fin voila une manip :

1/ Selectionner la première cellule puis appuyer simultanément sur CTRL + Maj + Flêche vers le bas . Attention il selectionne jusqu'a la derniere cellule non vide de la colonne. Donc quand on veut ecrire une meme formule sur toute une colonne on peut mettre juste dans la dernière case une valeur quelconque.
2/ Puis on tape la formule qui correspond à la première cellule selectionnée dans la ligne de saisie des formules.
3/ on valide en apputant simultanément sur ENTREE + CTRL

A+
Cordialement,
glamcerise
Messages postés
119
Date d'inscription
samedi 6 octobre 2012
Statut
Membre
Dernière intervention
25 juillet 2013
1 -
la formule ne marche pas ... tant pis :)
J'ai fait manuellement, mais si quelqu'un a une autre idée ça pourra toujours servir.

Quand à l'astuce elle va bien m'aider !!! merci :)

Bonne soirée.

Laurie
pilas31
Messages postés
1854
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
1 avril 2019
511 -
C'est curieux, elle marche chez moi. je viens de la tester à nouveau....
glamcerise
Messages postés
119
Date d'inscription
samedi 6 octobre 2012
Statut
Membre
Dernière intervention
25 juillet 2013
1 -
Je vais re-tester ...
glamcerise
Messages postés
119
Date d'inscription
samedi 6 octobre 2012
Statut
Membre
Dernière intervention
25 juillet 2013
1 -
Il y a un problème de #valeur. Je ne sais pas d'où il vient.
Messages postés
587
Date d'inscription
mardi 10 août 2010
Statut
Membre
Dernière intervention
11 novembre 2018
247
0
Merci
Bonjour,

Regarde le fichier joint.

Si tu as des soucis, n'hésite pas

http://cjoint.com/?CCbpyuWe1gV

Bon courage
cousinhub29
Messages postés
587
Date d'inscription
mardi 10 août 2010
Statut
Membre
Dernière intervention
11 novembre 2018
247 -
Edit, je viens de voir une erreur, pour le 29/02...

Il faut diviser par 5, et non 21...

Scuse
pilas31
Messages postés
1854
Date d'inscription
vendredi 5 septembre 2008
Statut
Contributeur
Dernière intervention
1 avril 2019
511 -
Ta formule fonctionne parfaitement bien. Il n'y que pour le 29/2 qu'il y a une erreur.
Pour reprendre ta syntaxe avec les plages nommées. Tu peux écrire :
=SOMMEPROD((JOUR(dates)=CNUM(GAUCHE(D2;2)))*(MOIS(dates)=CNUM(DROITE(D2;2)))*haut)/SOMMEPROD((JOUR(dates)=CNUM(GAUCHE(D2;2)))*(MOIS(dates)=CNUM(DROITE(D2;2))))


Et ainsi sa fonctionne tout le temps même si tu ajoutes des observations

Bonne suite
cousinhub29
Messages postés
587
Date d'inscription
mardi 10 août 2010
Statut
Membre
Dernière intervention
11 novembre 2018
247 -
Yes,
Merci bien, j'avais un peu la flemme, étant en vacances....

Merci pour cette précision, je pense que glamcerise (je veux dire "Laurie") va pouvoir s'en sortir ainsi...

bonne soirée
glamcerise
Messages postés
119
Date d'inscription
samedi 6 octobre 2012
Statut
Membre
Dernière intervention
25 juillet 2013
1 -
Merci :) Je devrais m'en sortir avec ça déjà ^^
Messages postés
22735
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 mai 2019
5476
0
Merci
Bonjour à tous,

autre astuce pour recopier une formule :
sélectionner la cellule, double-cliquer sur la poignée de recopie (petit carré noir en bas à droite de la sélection).
Elle va se recopier jusqu'en bas. Soit en remplaçant ce qui est en-dessous, ou s'il n'y rien remplir tant qu'elle trouve qcq chose sur la colonne de gauche.

eric
glamcerise
Messages postés
119
Date d'inscription
samedi 6 octobre 2012
Statut
Membre
Dernière intervention
25 juillet 2013
1 -
Merci pour l'astuce :)
Bonne journée !