Erreur de connection à mysql a cause du mot de passe [Résolu/Fermé]

Signaler
Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
-
hautparleur
Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
-
Bonjour,

j'ai installé wamp et j'ai eu un problème avec mysql.
Il m'a dit que le serveur n'était pas protégé et qu'il fallait mettre un mot de passe à "root".
J'ai mis le mot de passe mais je ne peux plus me connecter à la page de phpMyAdmin.
Le message d'erreur:

MySQL a répondu:
#1045 - Access denied for user 'root'@'localhost' (using password: NO)

phpMyAdmin a tenté de se connecter au serveur MySQL, et le serveur a rejeté la connexion. Veuillez vérifier les valeurs de host, username et password dans votre configuration et vous assurer qu'elles correspondent aux informations fournies par l'administrateur du serveur MySQL.

Pourtant, je peux me connecter avec le mot de passe avec la console MuSql.
Comment faire pour me connecter? Merci!

14 réponses

Messages postés
9390
Date d'inscription
mardi 27 septembre 2005
Statut
Contributeur
Dernière intervention
16 décembre 2016
1 198
C'est pourtant écrit très fort :-)

"
phpMyAdmin a tenté de se connecter au serveur MySQL, et le serveur a rejeté la connexion. Veuillez vérifier les valeurs de host, username et password dans votre configuration et vous assurer qu'elles correspondent aux informations fournies par l'administrateur du serveur MySQL. "

Dans certains cas le mot de passe est inscrit en dur dans la configuration de PHPMA.

Donc il faut trouver le ficher de configuration et inscrire à l'intérieur le mot de passe du user ROOT


Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
14
Mais il y a plein de fichiers de configurations, et aucun ne parle de mot de passe!
Messages postés
9390
Date d'inscription
mardi 27 septembre 2005
Statut
Contributeur
Dernière intervention
16 décembre 2016
1 198
On va commencer plu simple :

quel OS ? Windows ou Linux?
PHPMA a été installé à part ou livré dans un logiciel type WampServer?
Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
14
windows.
phpmyadmin était avec wamp.
Messages postés
9390
Date d'inscription
mardi 27 septembre 2005
Statut
Contributeur
Dernière intervention
16 décembre 2016
1 198
Je l'ai installé vu que WAMP a pas mal changé depuis.

Pour ma part l'installation de PHPMA se trouve ici :

D:\Servers\WAMP\apps\phpmyadmin3.5.1

Par défaut celle-ci se trouve dans :

C:\WAMP\apps\phpmyadminx.x.x (en fonction de la version)

Le fichier à modifier se nomme config.inc.php, qui contient ces lignes :


..........
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = 'motdepasse';
$cfg['Servers'][$i]['AllowNoPassword'] = true;
........

Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
14
J'ai mis le mot de passe mais j'ai une erreur 403.
Il dit que je n'ai pas la permission d'entrer.
Messages postés
9390
Date d'inscription
mardi 27 septembre 2005
Statut
Contributeur
Dernière intervention
16 décembre 2016
1 198
L'installation intiale de WAMP a été touchée ou non?

Tel quel, je n'ai pas eu de souci à l'installation.

S'il ne s'agit pas de la dernière version, et que vous n'avez pas commencé à programmer, alors je conseille de désinstaller et de réinstaller au propre.

Sachant que MySQL est sur le poste, et à moins qu'il y ait au moins un autre utilisateur sur le poste, il n'y aura pas de raison de mettre de mot de passe à ROOT.
Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
14
Je n'ai touché a aucune option.
Ça ma l'a déjà fait, mais quand on redémare le service ça remarchait, mais plus maintenant.
Messages postés
9390
Date d'inscription
mardi 27 septembre 2005
Statut
Contributeur
Dernière intervention
16 décembre 2016
1 198
Quand vous ouvrez la page PHPMA quelle est l'URL qui s'affiche?
Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
14
Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
14
J'ai désinstaller et ré-intallé wamp mais sur phpmyadmin il dit toujours:

Forbidden
You don't have permission to access /phpmyadmin/ on this server.
Messages postés
9390
Date d'inscription
mardi 27 septembre 2005
Statut
Contributeur
Dernière intervention
16 décembre 2016
1 198
Je pense à un problème de config de vhost à l'installation.

Il faudrait vérifier le fichier de config des vhost apache.
Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
14
Je crois que il m'interdit l'acces aux alias, je les ai testés, mais ils ne marchent pas non plus.
C'est où les config des vhost?
Messages postés
213
Date d'inscription
mercredi 9 janvier 2013
Statut
Membre
Dernière intervention
13 mai 2016
14
J'ai redésinstallé wamp, et j'ai supprimé les configs après, comme elles étaient réstées.
Je ne peux pas me connecter avec l'adresse localhost, seulement avec 127.0.0.1.
Mais ça marche.