Double recherche verticale [Résolu/Fermé]

Signaler
Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
-
pijaku
Messages postés
12262
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
5 mars 2020
-
Bonjour à tous,

Je m'arrache les cheveux surement pour un oubli basique ... mais c'est plus qu'énervant... du coup je vous demande un coup de pouce.

Rôle de la formule conditionnelle :
Recherche verticale d'une valeur dans un classeur. Si la recherche verticale ne donne rien alors faire une seconde recherche verticale dans un second classeur sinon écrire "Non référencé".

Ma formule qui me débite "Non référencé" partout ... :
=SI((ESTVIDE(RECHERCHEV(Q2;'[Mise à jour de parc.xls]Partitions'!$A$2:$D$6864;4;FAUX)));RECHERCHEV(Q2;'[Suivi_DRI_inter_SD.xls]DSI et Autres'!$X$2:$AL$65536;15;FAUX);"Non référencé")

Merci pour tout aide



J'ai envoyé un ange pour te protéger mais ... il est revenu me dire qu'il ne pouvait veiller sur un autre

8 réponses

Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
868
Bon ... j'ai l'impression que ce n'est pas la formule ESTVIDE qu'il faut que j'utilise ... mais alors quoi ?
Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
868
Je relance le sujet,

Aucune idée ? Aucun avis ?
Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 191
Bonjour,

peut être faire SI(NON(ESTVIDE(.....));RECHERCHEV(...);"Non référencé")

Cordialement.
Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
868
Bonjour Chossette,

merci pour ta réponse, je test ça dans l'après midi et je te fais un retour sur ce post !
Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
868
Bon non ... en faite j'ai juste à rajouter le NON, j'ai vérifié, il est bien positionné mais j'ai une erreur #N/A ...


J'ai envoyé un ange pour te protéger mais ... il est revenu me dire qu'il ne pouvait veiller sur un autre
Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 191
En fait que cherches tu à faire ?

Une première rechercheV, mais si la valeur retournée est vide, tu fais une seconde rechercheV, et si celle-ci plante tu marques "non référencé" ?
C'est bien ça ou j'ai mal compris ?

Cordialement.
Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
868
Exactement c'est ça ! Par contre (effectivement en relisant la description je n'ai pas mis ce point) ce n'est pas si la recherche plante, c'est si la valeur cherchée n'est pas trouvée après ces 2 recherches dans ces 2 classeurs ... on écrit "non référencé"

Cordialement

EDIT : je viens de parcourir ce topic ... je rencontre toujours des erreurs. Ou bien "non référencé" partout ou bien "#N/A"

J'ai envoyé un ange pour te protéger mais ... il est revenu me dire qu'il ne pouvait veiller sur un autre
Messages postés
12262
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
5 mars 2020
2 369
Bonjour tout ce beau monde,

En fait, lors d'une recherchev il y a plusieurs facteurs qui peuvent entrer en jeu, sinon ça ne serait pas amusant...

=RECHERCHEV("toto";A2:C28;3;0) peut retourner :
- une valeur si tout est ok,
- #N/A si "toto" n'est pas en colonne A
- 0 (ou vide) s'il n'y a rien en colonne C en vis à vis de "toto"
- etc...

Par exemple, si toto n'existe pas en colonne A, cette formule affiche "toto pas la" :
=SI(ESTERREUR(RECHERCHEV("Toto";A2:C28;3;0));"toto pas la";"toto la")

Si toto est bien en colonne A mais que la cellule en C est vide, la formule suivante affiche "OK" :
=SI(ESTVIDE(RECHERCHEV("Toto";A2:C28;3;0));"OK";"")

Pour ta formule, il faut voir dans quel(s) cas tu te trouves...... Ou alors tester tous les cas.
dyllan
Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
868
Bon, après test, j'ai des résultats. Merci Pijaku, c'est plus qu'un excellent départ : )

Je confirme par série de test en plus. Ce sera surement Lundi ... là je suis HS et c'est ma tête qui va explosée !

A très vite
pijaku
Messages postés
12262
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
5 mars 2020
2 369
pour "t'amuser" ce week end : tout sur la RECHERCHEV ou presque...

Sinon, pour ton mal de tête, je te recommande la RECHERCHEV multi tables avec formule matricielle !!!! Rien de tel pour aggraver ton cas.

Bon week à toi
et à Chaussette
dyllan
Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
868
Merci mais sincèrement ... non :D

Bon week à vous deux aussi ! Je passerais le post en résolu après validation Lundi
dyllan
Messages postés
4721
Date d'inscription
mardi 9 janvier 2007
Statut
Contributeur sécurité
Dernière intervention
25 juin 2019
868
Bonjour Pijaku,

je valide la formule c'est impeccable ! Merci pour ton support. Si je rencontre d'autres difficultés je n'hésiterai pas ;)

A bientôt, je clos ce sujet.

Cordialement
pijaku
Messages postés
12262
Date d'inscription
jeudi 15 mai 2008
Statut
Modérateur
Dernière intervention
5 mars 2020
2 369
Salut Dyllan,

N'hésite surtout pas.

A+