Excel 2010 condition SI ET SAUF [Fermé]

Signaler
Messages postés
90
Date d'inscription
lundi 4 juin 2012
Statut
Membre
Dernière intervention
1 novembre 2019
-
gbinforme
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
-
Bonjour,

J'ai les données suivantes :

- Type de mouvement : Entrée ou Sortie (colonne C)
- Clé de pointage : "X" si pointé sinon " " (colonne K)
- Quantité (colonne M)
- Stock (colonne L)
- Type de sortie (colonne G) qui peut être "COMP" pour comptoir - "CATAL" pour catalogue - "DIFF" pour les ventes à 30 jours ou INTE pour Internet.

d'où la formule suivante pour gestion de mon stock (formule actuelle)

=SI(ET(C3="Entrée";K3="x");L2+M3;SI(ET(C3="Sortie";K3="x");L2-M3;L2))

Je souhaiterais pouvoir connaître mon stock exact en permanence - En clair ne pas comptabiliser les sorties si la colonne G est égale à "DIFF"

Je voudrais donc intégrer dans mon calcul :
si type sortie = "DIFF" et clé de pointage = " ", mon stock n'évolue pas
si type sortie = "DIFF" et clé de pointage = "X" mon stock évolue.

J'espère avoir décrit correctement ma demande et vous remercie par avance de vos conseils.

Cordialement.



windows XP / Firefox 18.0</config>

1 réponse

Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
3799
Bonjour,

si type sortie = "DIFF" et clé de pointage = " ", mon stock n'évolue pas
si type sortie = "DIFF" et clé de pointage = "X" mon stock évolue.


Tu dois avoir une incohérence car lorsque la clé = "x" ton stock évolue et si tu rajoutes ce test cela ne changera rien.