Somme valeurs positives uniquement sur cellules espacées [Résolu/Fermé]

-
Bonjour,

Alors voila mon problème

J'ai une ligne ou les cellules affichent les resultats de différents calculs.

Parfois la valeur de la cellule est positive, parfois négative.

Je ne parviens pas a trouver la formule adéquate qui pourrait correspondre à la formule suivante (formule qui ne marche pas et dont je n'arrive pas a trouver l'astuce):

SOMME.SI(A3+A5+A7);>"0"

Quelqu'un a t'il une idée pour corriger ma formule?

Merci d'avance (je suis sous Excel 2010)

Bonne soirée


Afficher la suite 

3 réponses

0
Merci
Bonsoir,

si aucune valeur numérique critique n'entre en A4 et A6 la formule
' =SOMME.SI(A3:A7;">0";A3:A7) devrait convenir

sinon, : =SI(A3>0;A3;0)+SI(A5>0;A5;0)+SI(A7>0;A7;0)
en espérant qu'il n'y en ait réellement pas plus d'une dizaine !

dans ce cas, une macro serait préférable

bonne suite
Cordialement
Messages postés
22973
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
5712
0
Merci
Bonjour,

ou bien :
=SOMMEPROD(MOD(LIGNE(A3:A7);2)*(A3:A7))
somme des lignes impaires de la plage A3:A7.
D'ailleurs c'est une colonne, pas une ligne...

eric

Jamais tu ne répondras à un mp non sollicité...
Bon, ça c'est fait.
0
Merci
Bonjour,

Merci pour vos réponses, ça fonctionne c'est génial.

Merci encore à vous

Bonne journée

Patrice