Somme valeurs dans une colonne suivant mois [Résolu/Fermé]

Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
- - Dernière réponse : Polmyna
Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
- 26 mars 2016 à 20:40
Bonjour à tous et merci par avance de votre accueil

j'ai deux colonnes selon les formats suivant

A..................B
2-janv.........12
12-janv.......15
1-août........10
30-août......12
3-sept........4
15-oct........78

je voudrais additionner les valeurs B selon le critère "mois" du tableau D:E, en sachant que le premier tableau s'allonge a fur et a mesure mais pas régulièrement dans le temps

D.....................E
janvier.........résultat
février..........résultat
etc..................etc
décembre....résultat

je n'ai pas su exploiter les diverses réponses trouvées sur le net, mes connaissances d Excel étant disons "primaires"

j'espère être assez clair dans ma question

merci d'avance



Afficher la suite 

9 réponses

Meilleure réponse
Messages postés
24608
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2019
4837
1
Merci
Bonjour
si vos dates en colonne A sont bien en format date:
exemple pour Janvier
=SOMMEPROD((MOIS($A$1:$A$1000)=1)*($B$1:$B$1000))

donc
en D les nombres désignant les mois de 1 à 12
en E la formule
=SOMMEPROD((MOIS($A$1:$A$1000)=D1)*($B$1:$B$1000))
et si vous voulez en D l'inscription des mois en toutes lettres:
entrer le 1 jour du mois en D (exemple 1/1/12)
formatez les cellules D en format personnalisé et type:
mmm
et en E la formule devient:
=SOMMEPROD((MOIS($A$1:$A$1000)=MOIS(D1))*($B$1:$B$1000))

si vous voulez aussi tenir compte de l'année, revenez, ,il faut simplement complèter un peu la formule.
crdlmnt


ne sommes nous pas seuls à comprendre ce que l'on explique?

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64110 internautes nous ont dit merci ce mois-ci

Polmyna
Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
-
merci je vais essayer
Messages postés
1265
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
140
0
Merci
Bonjour,
J'ai trouvé une solution, pas forcément la meilleure mais elle a le mérite d'exister (et de fonctionner).
Voici un fichier exemple pour t'aiguiller ;)
Polmyna
Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
-
ce n'est pas ce que je recherche, parce que les colonnes existantes font parties d'un tableau plus complexe, donc je ne peux pas rajouter de colonnes

merci quand même
Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
0
Merci
merci pour cette réponse

pas l habitude du forum excusez mo
Morgothal
Messages postés
1265
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
140 -
La solution de Vaucluse est bien meilleure que la mienne :)
Étonnamment je n'ai pas réussi à mettre en place les SOMMEPROD, du coup je me suis tourné vers les SI...
Voilà un fichier qui peut aider.
Vaucluse
Messages postés
24608
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
19 octobre 2019
4837 -
Re Morgothal
effectivement, j'ai été un peu surpris que tu n'ais pas pu proposer cette formule.
Pour info, on ne sait jamais:la formule exige des limites de champ avec indication de la colonne et de la, ligne impérativement;( A1:A10000 fonctionne, mais A:A ne convient pas.)
crdlmnt
Morgothal
Messages postés
1265
Date d'inscription
jeudi 22 avril 2010
Statut
Membre
Dernière intervention
19 mai 2015
140 -
Exact, je pense que je me suis planté la dessus, merci du correctif ;)

A+
Messages postés
16952
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 octobre 2019
3632
0
Merci
Salut,

je remet mon post qui n'a pas été pris en compte bien que mon ami Vaucluse que je salue, du coup m'a devancé

Il faut faire attention au format de saisie des dates en colonne A, respecter un format reconnu par Excel
La formule pour le mois de janvier avec index mois est
=SOMMEPROD((MOIS(A1:A20)=1)*B1:B20)
ou avec saisie du mois
=SOMMEPROD((MOIS(A1:A20)=MOIS(1&"janvier"))*B1:B20)
=SOMMEPROD((MOIS(A1:A20)=MOIS(1&"jan"))*B1:B20)
il est possible de faire référence à une cellule contenant le critère mois, avec index mois ex. 1 pour janvier en D1
=SOMMEPROD((MOIS(A1:A20)=D1)*B1:B20)
ou le critère saisi janvier ou jan
=SOMMEPROD((MOIS(A1:A20)=MOIS(1&D1))*B1:B20)


A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Polmyna
Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
-
encore merci

j'ai essayé toutes les formules en les transposant sur mon tableau et c'est nickel, toutes fonctionnent (après quelques tâtonnements lol )

mais comme j'aime bien comprendre ce que je fais, pourriez vous m'expliquer, sans abuser, le déroulement des formules, car je n 'ai pas compris l histoire somme produit
Messages postés
16952
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 octobre 2019
3632
0
Merci
Re,

SOMMEPROD fonction Excel permet de faire une somme en fonction d'un ou plusieurs critères
(MOIS(A1:A20)=1) dans ton cas est le critère de recherche mois correspondant au premier mois de l'année, pour mars par exemple je saisirai (MOIS(A1:A20)=3)
ce critère peur être placé dans la formule ce qui la rend fixe ou on fait référence à une cellule contenant ce critère ce qui permettra d'utiliser la formule pour tous les mois vu que le critère changera dans la cellule de référence ex (MOIS(A1:A20)=D1)
Dans le cas ou le mois est saisi ex janvier ou jan, Excel considérera cette saisie comme texte, il faudra écrire
MOIS(1&"janvier")
Excel associera 1 pour janvier 2 pour février etc ce qui servira d'index à la formule.
il serait également possible de saisir une date comme critère et d'en extraire dans la formule le mois ce qui alourdirait la formule. il serait également possible de prendre en compte une fourchette de jours ou l'année comme le suggérait mon ami Vaucluse dans son premier post

)*B1:B20) est la zone de recherche des valeurs à additionner correspondantes
Polmyna
Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
-
merci et encore merci pour ces explications
appliquer c'est bien mais comprendre c'est mieux
Messages postés
16952
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 octobre 2019
3632
0
Merci
RE,

un petit conseil pour tester une formule, prenons comme exemple celle ci
=SOMMEPROD((MOIS(A1:A20)=MOIS(1&"jan"))*B1:B20)
lorsque la cellule contenant la formule est activée, ta formule est visible dans la barre des formules, si tu veux tester cette partie MOIS(A1:A20) de la formule
il suffit de la mettre dans la barre des taches cette partie en surbrillance et clic sur la touche de fonction F9,
s'affichera ceci la troisième date que j'ai saisi correspond au mois de février
{1;1;2;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1;1}
pour tester MOIS(A1:A20)=MOIS(1&"jan")
la formule renverra vrai pour les cellules remplissant la condition vrai
{VRAI;VRAI;FAUX;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI;VRAI}
si tu mets en surbrillance cette partie B1:B20
tu verras les valeurs de la plage
{0;10;0;20;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0}
pour sortir de la fonction Echap
ceci est valable pour tester toutes les formules
Polmyna
Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
-
merci pour ces précisions
Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
0
Merci
bonjour
je fais remonter ce sujet, car nouvelle question en rapport

j'utilise sur excel cette formule qui fonctionne super
=SOMMEPROD((MOIS($A$6:A47)=MOIS(1&S17))*$I$6:I47)

le truc est qu'étant passé sous Libre Office, cette formule ne fonctionne pas
et me renvoi #VALEUR!
si quelqu'un peut me donner la solution, merci d'avance
Messages postés
16952
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
15 octobre 2019
3632
0
Merci
Re,

exemple, cette formule pour le mois de janvier
=SOMMEPROD((MOIS(A1:A20)=MOIS(1&"jan"))*B1:B20)
sera remplacée par
=SOMMEPROD((MOIS(A1:A20)=1)*B1:B20)

Messages postés
10
Date d'inscription
mardi 26 février 2008
Statut
Membre
Dernière intervention
26 mars 2016
0
Merci
merci
ça fonctionne