Copier des données Excel sous condition [Résolu/Fermé]

Messages postés
2
Date d'inscription
vendredi 6 juillet 2012
Statut
Membre
Dernière intervention
6 juillet 2012
- - Dernière réponse : BOTOX81
Messages postés
2
Date d'inscription
vendredi 6 juillet 2012
Statut
Membre
Dernière intervention
6 juillet 2012
- 6 juil. 2012 à 16:20
Bonjour,

Je viens vers vous car je ne maîtrise absolument pas VBA.

Je vous explique mon soucis :

Je possède deux feuilles Excel.
Sur ma première feuille ma colonne C recense des noms de clients.
Sur ma deuxième feuille ma colonne B recense aussi des noms de clients.

Je voudrais récupérer les infos des colonnes C,D,E,F de ma deuxième feuille si le nom de client est identique à celui de ma première feuille et ainsi compléter mes colonnes H,I,J,K de ma première feuille.

Je voudrais mettre en place une macro qui parcours mes 2 feuilles et remplit ma première feuille.

Je vais essayer de m'expliquer en algorythmie.

nommons 1 la feuille 1
nommons 2 la feuille 2

Pour chaque valeur de la colonne C(1)

Pour chaque valeur de la colonne B(2)

Si la cellule B(2) = cellule C(1) alors
copie en H(1) de la cellule C(2)
copie en I(1) de la cellule D(2)
copie en J(1) de la cellule E(2)
copie en K(1) de la cellule F(2)

Sinon lire la cellule B(2) suivante
Fin SI
C(1) + 1

J'espère que ma demande est claire. Merci à tout ceux qui se pencherons sur mon problème.


Afficher la suite 

2 réponses

Messages postés
9516
Date d'inscription
mercredi 11 août 2004
Statut
Contributeur
Dernière intervention
18 septembre 2019
988
0
Merci
Bonjour,
En supposant que le nom du client est unique dans la colonne [C] feuille 1 et de même pour [B] feuille 2 vous pouvez utiliser la fonction RECHERCHEV() comme suit :
Feuille 1 colonne [H] ligne 2 (supposer Titre en ligne 1)
En [H2]
=RECHERCHEV(C2;Feuil2!B:F;2;0)

En [I2]
= RECHERCHEV(C2;Feuil2!B:F;3;0)

Etc.
Pour terminer, incrémenter la formule, sélectionner la plage [H2 :K2] et tirer vers le bas
Messages postés
2
Date d'inscription
vendredi 6 juillet 2012
Statut
Membre
Dernière intervention
6 juillet 2012
0
Merci
Merci beaucoup pour la réponse, cela solutionne mon problème :)

Tu m'enlève une épine du pied.

Merci