Vba : somme si date = mai [Résolu/Fermé]

Messages postés
471
Date d'inscription
mardi 1 juin 2004
Statut
Membre
Dernière intervention
21 février 2018
- - Dernière réponse : moiced59
Messages postés
1144
Date d'inscription
samedi 15 novembre 2008
Statut
Membre
Dernière intervention
18 août 2014
- 4 juin 2012 à 19:19
Bonjour,
j'ai des dates dans une colonnes et je voudrais une formule qui me calcule combien de ligne ont pour mois : mai

30/05/2012
31/05/2012
01/06/2012
02/06/2012
03/06/2012
04/06/2012
05/06/2012
06/06/2012
07/06/2012
08/06/2012
09/06/2012
10/06/2012
11/06/2012
12/06/2012
exemple de ligne.

cordialement



Afficher la suite 

3 réponses

Messages postés
23911
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
18 mars 2019
2683
0
Merci
Salut,

la fonction nb.si combinée avec une fonction mois() ?
ViriisXP
Messages postés
471
Date d'inscription
mardi 1 juin 2004
Statut
Membre
Dernière intervention
21 février 2018
36 -
je sais pas si c'est nb.si enfin je pense pas même....

en gros : http://cjoint.com/?BFel2WMNR6F
mais sans avoir a dénaturer mon tableau en créent la colonne 3

je veux en L20C2 la fonction qui me calcule le nombre de fois ou le mois est 5 ! :)
ViriisXP
Messages postés
471
Date d'inscription
mardi 1 juin 2004
Statut
Membre
Dernière intervention
21 février 2018
36 -
tu vois un truc du genre : =NB.SI(L(-16)C:L(-3)C;"*/05/*")
blux
Messages postés
23911
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
18 mars 2019
2683 -
Donc, si c'est toi qui donne la formule, je ne vois pas ce que je peux faire de plus !
ViriisXP
Messages postés
471
Date d'inscription
mardi 1 juin 2004
Statut
Membre
Dernière intervention
21 février 2018
36 -
mais ca ne marche pas ca serais trop beau ^^

mais j'ai trouvé ^^
Total du mois de juin :
=SOMME(SI(MOIS(L2C2:L15C2)=6;1)) 

'ou 6 = le mois désiré


fichier cjoint.com pour ceux que ca peut interesser :
http://cjoint.com/?BFenKPTTZgw
blux
Messages postés
23911
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
18 mars 2019
2683 -
D'après toi, si je t'ai parlé de la fonction mois(), c'est qu'il y avait un intérêt, non ?
Messages postés
1144
Date d'inscription
samedi 15 novembre 2008
Statut
Membre
Dernière intervention
18 août 2014
56
0
Merci
Bonjour

Sinon ya une formule toute faites pr ca :

=NB.SI.ENS(B11:B46;">=01/05/2012";B11:B46;"<01/06/2012")


B11: B46 plage des dates
Messages postés
15977
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 novembre 2019
2824
-1
Merci
Bonjour,
=SOMMEPROD((MOIS(A1:A14)=5)*1)

aucun intér^t à utiliser VBA....

Michel
michel_m
Messages postés
15977
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 novembre 2019
2824 -
merci pour le -1 et le courage de l'anonyme
blux
Messages postés
23911
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
18 mars 2019
2683 -
Ce n'est pas un anonyme qui t'a moinssoyé...
michel_m
Messages postés
15977
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
19 novembre 2019
2824 -
c'est toi?
blux
Messages postés
23911
Date d'inscription
dimanche 26 août 2001
Statut
Modérateur
Dernière intervention
18 mars 2019
2683 -
Je n'avais aucune raison de le faire...