Clé USB en "lecture seule", que sous Ubuntu [Fermé]

-
Bonjour,

J'ai besoin de mettre un fichier volumineux (5Go) sur une clé USB de 8go.
Elle était au début en FAT32 et me mettait un message d'erreur une fois les 4go dépassés.
Je l'ai formaté (après beaucoup de mal...) en NTFS.
Maintenant je ne peux même plus du tout copier un fichier sur cette clé, j'obtiens un message d'erreur me disant que la clé est en "Lecture seule"... sous Ubuntu seulement.

Sur Windows par contre ça marche très bien et il n'y a aucun problème.

Le problème est que justement ce fichier volumineux n'est pas sur cet ordi possédant Windows.

Comment pourrais-je utiliser cette clé USB sur Ubuntu ?

Merci d'avance,
Léo.
Afficher la suite 

2 réponses

Meilleure réponse
1
Merci
Bonjour,
Ça serait peut-être plus rapide de lancer gparted sous linux, sélectionner la clé, supprimer la partition récalcitrante et en créer une nouvelle formatée en ntfs.
Gparted te fait ça en un tour de main...

Dire « Merci » 1

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 60187 internautes nous ont dit merci ce mois-ci

Tu as supprimé la partition ?
J'ai essayé en supprimant la partition, puis en en recréant une en NTFS.
Toujours le problème de lecture seule.
Alors essaie de faire une vérification du système de fichiers avec gparted.
Est-ce que tu as le même problème si tu la convertis en fat 32 ?
Comment est-ce qu'on fait une vérification du système de fichiers ?
EDIT : ah j'ai trouvé : clic-droit sur la partition : Vérifier.
Et donc même après avoir "Vérifié et réparé le système", la clé est toujours en lecture seule.

Aucun problème d'écriture quand j'ai ma clé en FAT32.

(J'espère que ça n'abîme pas les clés de les formater sans arrêt ^^' )
Votre astuce marche très bien
Grand Merci!
Messages postés
14736
Date d'inscription
samedi 9 décembre 2006
Statut
Contributeur
Dernière intervention
5 juillet 2019
1946
0
Merci
bonjour,
en passant par sudo cp tonfichier/media/tacle
le ntfs requiert des droits au contraire du fat32
a+
jeanbi
Messages postés
14736
Date d'inscription
samedi 9 décembre 2006
Statut
Contributeur
Dernière intervention
5 juillet 2019
1946 -
re
sous w$ demonte la correctement par l'option retirer le periph en toute securite
si ça ne fonctionne toujours pas , il te faudra monter la cle avec l'option -force de mount
a+
Ah oui bonne idée.

Donc je la démonte, puis je tape la commande sudo cp fichier clé, l'ordi mouline pendant 3 ou 4 minutes puis le Terminal ne me donne aucun message d'erreur et retourne à la normale (a priori, tout s'est bien passé).

Mais quand je débranche et rebranche la clé, elle est toujours vide :S


PS : "Sous w$" veut dire "graphiquement" ? (Clic-droit sur la clé dans le lanceur Unity)
En fait je me suis aperçu qu'en faisant ça, le Terminal créait un fichier sans extension du même nom que la clé, dans le dossier /media
laoshu
Messages postés
1232
Date d'inscription
mardi 7 juin 2011
Statut
Membre
Dernière intervention
24 mai 2015
242 -
Bonjour,

Quand tu tapes «sudo cp fichier clé», que prends tu comme «clé» ?
Si tu prends /dev/sd... il est assez normal que ça ne marche pas.

Essaye avec :
sudo mount /dev/sd... /mnt
sudo cp fichier /mnt

Ou bien : sudo cp fichier /media/ta_clé
(ce qui revient au même)

Pour créer simplement un système de fichier NTFS sur ta clé, depuis un terminal la commande est normalement assez simple :
mkntfs /dev/sd...

Ceci dit, attention a ne pas te tromper dans le /dev/sd... les conséquences d'une faute de frappe ou d'inattention peuvent être dramatiques...
J'avais fait :
sudo cp fichier /media/clé

Pour l'instant j'ai réussi à mettre mon fichier en passant par un autre ordi qui a Windows. Mais j'espère qu'on trouvera une solution...