Excel 2007: fonction si à répétition (courte) [Résolu/Fermé]

Signaler
Messages postés
9
Date d'inscription
mardi 27 mars 2012
Statut
Membre
Dernière intervention
31 mars 2012
-
po4419
Messages postés
9
Date d'inscription
mardi 27 mars 2012
Statut
Membre
Dernière intervention
31 mars 2012
-
Bonjour,

J'ai une question concernant la fonction "si". Je cherche à savoir si la formule que j'ai est la plus simple qu'il soit?

Exemple:
J'ai deux feuilles de travail:
Dans une prémière feuille (feuil1):
En colonne A, il peut y avoir une des cinq différentes données textes suivantes:
Très_Bon; Bon; Neutre; Mauvais; Très_mauvais
(qui correspond à la feuil2 A1, A2, A3, A4 et A5. Donc, les cases suivantes de la feuil2: B1, B2; B3; B4 et B5, sont des notes (5;4;3;2;1) associés à la case A de la même ligne.
En colonne B de la feuil1: voici ma formule:
Si(A1=feuil2!A1;feuil2!B1;(si(A1=feuil2!A2;feuil2!B2;(si(A1=feuil2!A3;feuil2!B3;... et ainsi de suite jusqu'à avoir les cinq données textes et fermer les paranthèses.

Y-a-t'il une formule plus courte que nous pourrions utiliser?
Surtout dans le cas, où le nb de données textes est de beaucoup supérieur à 5.

Merci!!

Po4419

2 réponses

Messages postés
16083
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 février 2020
2 877
Bonjour

avec une liste à validation de données feuil1

=RECHERCHEV(A1;Feuil2!A$1:B$5;2;0)

sans
=SI(NB.SI(A$1:A$5;A1)=0;"inconnu";RECHERCHEV(A1;Feuil2!A$1:B$5;2;0))

à tirer vers le bas
Messages postés
9
Date d'inscription
mardi 27 mars 2012
Statut
Membre
Dernière intervention
31 mars 2012
3
Merci Michel,

Ça fonctionne très bien!!

Po4419