Excel 2007: RechercheV de 2 cellules [Fermé]

Signaler
Messages postés
9
Date d'inscription
mardi 27 mars 2012
Statut
Membre
Dernière intervention
31 mars 2012
-
po4419
Messages postés
9
Date d'inscription
mardi 27 mars 2012
Statut
Membre
Dernière intervention
31 mars 2012
-
Bonjour,

Je chercher à utiliser la formule "recherchev" de façon à avoir comme condition deux celulles recherchés. Je vais essayer de me faire plus clair par un exemple:

feuil1 (livraison)
date-------ingrédients-----prix
2012-03-01-----Maïs------200$
2012-03-01-----Orge-----230$
2012-03-02-----Blé-------250$
2012-03-03-----Maïs------205$
2012-03-06-----Maïs------210$
...

feuil2 (coût_ingrédients) à la journée
date-------------Maïs------Orge------Blé
2012-03-01-----formule?
2012-03-02
2012-03-03
2012-03-04
...

Donc, à la case formule?, je voudrais avoir le prix du Maïs en date du 2012-03-01. J'avais donc comme formule:
=RECHERCHEV($A2&$B$1;Livraison!$A:$C;3)
Je crois que mon problème est le " & ", mais je n'arrive pas à trouver la solution.
C'est ce que j'ai vu en cherchant sur le web, mais ça ne fonctionne pas avec le &.

Est ce que quelqu'un aurait une idée de la formule correcte à entrer?
Espérant que mon exemple a éclairci ma question!!

Merci

Po4419

4 réponses

Messages postés
16083
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 février 2020
2 877
Bonjour,
=sommeprod((Feuil1!$A$2:$A$6=A2)*(Feuil1!$B$2:$B$6=B$2)*(Feuil1!$C$2:$C$6))


si XL2007, tu peux utiliser la formule SOMME.SI.ENS (voir l'aide)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 86860 internautes nous ont dit merci ce mois-ci

Messages postés
9
Date d'inscription
mardi 27 mars 2012
Statut
Membre
Dernière intervention
31 mars 2012
3
Bonjour Michel,

Merci de votre aide! Mais, je n'ai pas réussi à faire fonctionner votre formule dans mon fichier excel. J'ai lu un peu sur cette formule, et, a moins que je me trompe, je crois que ce ne soit pas exactement ce que je cherche à faire.

Je me suis dit qu'il serait peut-etre plus simple de vous montrer le fichier en question. J'ai écrit en rouge, les informations du problème dans la feuille (Coût_ingrédients).
J'ai déjà une formule de transcris dans les cellules jaunes, mais ca ne fonctionne pas bien. Pcq, il peut avoir plus d'un ingrédients différents livrés dans la même journée:(dans la cellule "B6" de la feuille "Coût_ingrédients" du fichier ci-joint):

=SI(RECHERCHEV($A6;Livraison!$A:$G;2)=B$3;RECHERCHEV($A6;Livraison!$A:$G;3);B5)

L'autre que j'avais pensé, mais qui a, soit une erreur ou qui ne fonctionne pas:
=RECHERCHEV($A6&$B$3;Livraison!$A:$G;3)


Le but de ce fichier est de calculer la valeur quotidienne de différentes recettes de moulée selon le coût quotidien des ingrédients achetés. Les cellules entrées à la main dans ce fichier font parti des deux premières feuilles: recette! et Livraison!

Est ce que mon problème est solvable?

voir fichier:
http://cjoint.com/?BCDpBqqJ6Sg

Merci

Po4419
Messages postés
16083
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
22 février 2020
2 877
Désolé mais la formule proposée a été re-essayée sur une maquette et répond à la demande initiale après avoir mis un $devant A2:Feuil1!$A$2:$A$6=$A2

RechercheV est bien pratique mais est très limitée dans son utilisation...

A toi d'assumer en imposant à tout prix RECHERCHEV: je ne peux alors rien pour toi de m^me que si ta demande ne correspondait pas à ton désir
Michel
Messages postés
9
Date d'inscription
mardi 27 mars 2012
Statut
Membre
Dernière intervention
31 mars 2012
3
Eh bien, Wow!

Désolé Michel!
je ne comprends pas trop pourquoi je n'ai pas réussi à faire fonctionner votre formule la première fois. Je me suis repris avec plus de précision, et cette fois ci, cela a fonctionner. Et ça fonctionne très bien.

Par contre, je ne comprends toujours pas comment la formule fonctionne exactement, mais en changeant les numéro de ligne et colonne, ça fonctionné.
J'ai aussi ajouté ma deuxième demande dans la formule, la voici pour le fichier ci-joint (pour autre personnes interressées):

=SI(SOMMEPROD((Livraison!$A$4:$A$501=$A5)*(Livraison!$B$4:$B$501=B$3)*(Livraison!$C$4:$C$501))=0;B4;SOMMEPROD((Livraison!$A$4:$A$501=$A5)*(Livraison!$B$4:$B$501=B$3)*(Livraison!$C$4:$C$501)))


Merci encore!

Po4419