Menu

Excel Utilisation RechercheV et Indirect [Résolu/Fermé]

Messages postés
5
Date d'inscription
jeudi 9 février 2012
Statut
Membre
Dernière intervention
13 juillet 2012
- - Dernière réponse : Latrix
Messages postés
5
Date d'inscription
jeudi 9 février 2012
Statut
Membre
Dernière intervention
13 juillet 2012
- 9 févr. 2012 à 11:58
Bonjour,


Je souhaite effectuer une recherche V sur une plage de cellule d'une autre feuille non générique. Pour cela, j'utilise la formule suivante :

=RECHERCHEV(I6;INDIRECT("'"&F6&"'!A5:G100");7)

- I6 contient la valeur à rechercher
- F6 contient le nom de la feuille sur laquelle faire la recherche
- A5:G100 : la plage où je souhaite rechercher la valeur en F6
- 7 la colonne que je souhaite récupérer

Mon problème est que cette formule me renvoie systématiquement la colonne 7 de la dernière ligne de la plage.
(exemple si je mets G50 à la place de G100, je récupère la colonne 7 de la ligne 50 alors que la valeur à rechercher se trouve en G25).

Par avance, merci pour votre aide.
Afficher la suite 

6 réponses

Meilleure réponse
Messages postés
15825
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
20 mai 2019
3622
7
Merci
re,
=RECHERCHEV(I6;INDIRECT("'"&F6&"'!E5:G100");3;0)

recherchev "recherche" (...) dans la première colonne à gauche du tableau source;comme tu avais marqué A5:G100, il ne trouvait pas "rallongement" d'où le sinistre NA
Michel

Dire « Merci » 7

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 39139 internautes nous ont dit merci ce mois-ci

Messages postés
15825
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
20 mai 2019
3622
0
Merci
bonjour,
un petit oubli dans la formule (voir l'aide F1)
=RECHERCHEV(I6;INDIRECT("'"&F6&"'!A5:G100");7;0)

nota: problème de formule ==> forum bureautique
Messages postés
5
Date d'inscription
jeudi 9 février 2012
Statut
Membre
Dernière intervention
13 juillet 2012
0
Merci
Bonjour michel_m,

Merci pour la réponse.
En rajoutant le "0" à la fin, j'ai un #N/A (j'en conclue donc qu'il ne trouve pas ma valeur en I6...alors qu'elle est pourtant bien présente).
Les types des cellules sont les mêmes, il n'y a pas de problème de syntaxe...

Je ne suis pas contre utiliser le vba si quelqu'un à une idée.

dois-je déplacer le sujet moi même dans le forum bureautique ?
Messages postés
15825
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
20 mai 2019
3622
0
Merci
re,

dois-je déplacer le sujet moi même dans le forum bureautique ?
Non, c'est pour les prochaines fois

le mieux serait de mettre ton classeur en pièce (ou un extrait si classeur volumineux

pour joindre une pièce
mettre le classeur sans données confidentielles en pièce jointe sur
http://cjoint.com/
et faire un clic droit sur le lien proposé puis "copier l'adresse du lien" et coller dans le message de réponse

Messages postés
5
Date d'inscription
jeudi 9 février 2012
Statut
Membre
Dernière intervention
13 juillet 2012
0
Merci
Voilà le fichier :

http://cjoint.com/?BBjj3ReLTKH


La formule se trouve en feuille 1 Y6

Encore une fois merci pour ton aide.
Messages postés
5
Date d'inscription
jeudi 9 février 2012
Statut
Membre
Dernière intervention
13 juillet 2012
0
Merci
Merci beaucoup, ça fonctionne.