Menu

Thunderbird lecture caractères avec accents [Résolu/Fermé]

Messages postés
49
Date d'inscription
jeudi 29 septembre 2005
Dernière intervention
5 juin 2008
- 19 oct. 2006 à 09:33 - Dernière réponse :
Messages postés
4798
Date d'inscription
mercredi 19 avril 2006
Statut
Contributeur
Dernière intervention
10 juin 2015
- 17 sept. 2012 à 10:09
bonjour à tous

j'ai un pb avec ma messagerie thunderbird.
dans certains messages reçus les caractères accentués ex: "èéç... sont remplacés par d'autres caratères de la table ASCII ex: §@...
En demandant à une des personnes concernées, j'ai compris qu'elle m'écrivait depuis la messagerie du site Wanadoo, alors je lui ai demandé de m'écrire avec le corriellleur dont elle disposait (outlook express) pour tester et là j'ai eu un décodage parfait du message par thunderbird.
le pb vient donc de l'emetteur du message?

je précise que j'utilise thunderbird depuis 10 jours, avant j'utilisais outlook et n'avais aucun pb de décodage avec mes messages reçus des mêmes emetteurs.

Merci d'avance si quelqu'un a une soluce ou même expérience
Afficher la suite 

30 réponses

Meilleure réponse
- 26 août 2009 à 09:11
14
Merci
Je vous conseille cette méthode qui, après divers autres essais infructueux, c'est révélé être la bonne (le choix UNICODE Utf-8 peut être modifié aec un autre encodage, mêem si c'est certainement le moins risqué de tous). Attention, les trois modifications doivent être faites :

1 - Clic droit sur dossier entrant (et sortant) de l’adresse, propriétés, codage par défaut (décocher « appliquer par défaut à tous les messages du dossier ») > Unicode Utf-8
2 –Affichage, Encodage des cractères, > Unicode Utf-8, Détection Automatique – désactivée
3 - Outils - Options - Affichage – Polices > Unicode Utf-8 + deux cases dessous décochées

Merci oiseau tonnerre 14

Avec quelques mots c'est encore mieux Ajouter un commentaire

CCM a aidé 28068 internautes ce mois-ci

Pour l'instant, la réponse d'oiseau du tonnerre semble la meilleure et règle les problèmes récents SAUF dans l'en-tête d'un message où les accents sont remplacés par des ???. Je continue donc pour quelque temps pour voir si le problème est vraiment réglé.

Je suis au Québec et je reçois fréquemment des messages en français, du Québec et d'Europe ainsi qu'en anglais. Avec Windows Vista et Windows Mail, j'utilise l'encodage "Alphabet occidental" sans problème et non unicode-8. En tentant d'utiliser TB, je découvre souvent ce problème d'accents remplacés par des ? où il me faut remplacer l'encodage par Unicode-8 pour retrouver toutes les lettres.

Il est étonnant que cette "particularité" déconcertante persiste encore en fin de 2009 et ce, depuis au moins 3 ans (premières questions à cet effet ici)
Messages postés
4
Date d'inscription
lundi 28 juillet 2003
Dernière intervention
29 mai 2010
- 29 mai 2010 à 19:50
Super ça fonctionne ! Merci à toi
Enfin une réponse qui conviens parfaitement!
Merci 1000x
11
Merci
J'ai eu le meme pb. Je m'en suis sorti en allant dans "Outils" - "Options" - "Affichage" - "Polices" et en décochant les options "Appliquer le codage..." et "Utiliser le codage...".
A+
depuis ce message, j'ai trouvé la solution! dans le forum Geckozone de Thunderbird: de Demot » 23 Jan 2012, 12:43
Pas trouvé mieux depuis TB2 et dans les versions successives : (le msg s'ouvre avec l'encodage approprié)

Dans Options > Affichage > Formatage > Avancé ? Sélectionner :
occidental (iso-8859-1)
occidental (iso-8859-1)
Cocher ? Autoriser les messages à utiliser d'autres polices
Décocher ? Quand c'est possible utiliser l'encodage par défaut dans les réponses

Dans la Barre de Menu > Sélectionner :
Affichage / Encodage des caractères > Détection automatique ? Universel

Sur les dossiers (ex : Courrier entrant)
Clic droit > Propriétés * Décocher ? Appliquer par défaut à tous les messages du dossier
(Ignorer l'autodétection ainsi que l'encodage spécifique par message)

Dans l'Editeur de configuration ? Vérifier les valeurs (filtre : charset)
intl.charset.detector ? universal_charset_detector
mailnews.force_charset_override ? false
Bonjour, Pouvez-vous préciser les chemins et la syntaxe pour effectuer les modifications dans le registre ? Merci.
Affichage TB OUF ça marche 16 09 2012

je précise juste un peu plus le chemins surtout pour l'éditeur de configuration à la fin de la manip plus bas.

commencer par:

Dans Options > Affichage > Formatage > Avancé Sélectionner :
occidental (iso-8859-1)
occidental (iso-8859-1)
Cocher - Autoriser les messages à utiliser d'autres polices
Décocher - Quand c'est possible utiliser l'encodage par défaut dans les réponses

Dans la Barre de Menu > Sélectionner :
Affichage / Encodage des caractères > Détection automatique - Universel


Sur les dossiers (ex : Courrier entrant)
Clic droit > Propriétés * Décocher la case: Appliquer par défaut à tous les messages du dossier
(Ignorer l'autodétection ainsi que l'encodage spécifique par message)


Dans outils/option/avancé/général/ l'Editeur de configuration

Vérifier les valeurs (écrire comme « filtre » le mot : charset) :

intl.charset.detector ? universal_charset_detector
mailnews.force_charset_override ? false

maria
Bonjour Maria. Merci de vos indications. J'ai vérifié ma config et tout était OK. Il n'y a en réalité que les messages en provenance d'un expéditeur unique (depuis peu de temps d'ailleurs) qui ont les caractères accentués tronqués ; tous les messages d'autres correspondants me parviennent normalement. Le problème serait-il exclusivement chez cet expéditeur ? Si oui, pourquoi et comment faire ?
PSA
Messages postés
4798
Date d'inscription
mercredi 19 avril 2006
Statut
Contributeur
Dernière intervention
10 juin 2015
- 17 sept. 2012 à 10:09
Coucou psa,

Créés ta propre question : car l'auteur de cette question a résolu son problème.
2.beaucoup de gens risquent de passer à côté de : ta question ça serait :dommage quand même.
3.Si tu n'as qu'un expéditeur qui : t'envoie :des messages dont les caractères sont tronqués : il doit y avoir : un souci avec : son logiciel de : messagerie. Qu'utiluses-t-t il ?.
Pour la réponse crées ta question. Merci de ta compréhensiob
Messages postés
25778
Date d'inscription
samedi 8 juillet 2006
Statut
Contributeur sécurité
Dernière intervention
4 mars 2010
- 19 oct. 2006 à 10:14
2
Merci
Bonjour philozof
Tiens, tiens, le merveilleux, extraordinaire, fabuleux Thunderbird qui renvoie Outlook Express à l'âge pré-historique, aurait-il quelques défauts ?
Pardon pour cette remarque ironique que je n'ai pas pu retenir...
Plus sérieusement, je l'ai testé moi aussi et je dois reconnaître que je n'ai pas eu de problèmes, même avec des messages venus de Wanadoo. Essaie peut-être de le réinstaller, ça ne coûte rien, sinon, je ne vois pas.
Messages postés
49
Date d'inscription
jeudi 29 septembre 2005
Dernière intervention
5 juin 2008
- 19 oct. 2006 à 10:48
ok, merci de ton conseil, tu dis que tu l'as testé alors peut être ne l'utilises-tu plus?
sinon peux-tu m'indiquer ce que tu as choisi comme type d'encodage pour les messages entrant et sortant dans les options ?

moi j'utilise "occidental (euro) 8950-15" pour les 2

Merci d'avance
2
Merci
essaie ça, ça marche je l'ai testé.

Sinon par défaut, je conseille d'utiliser l'encodage UTF-8 qui est international.

pour retrouver les caractères normaux d'une BAL Thunderbird, tu fais un clic droit sur le dossier correspondant à ta BAL qui déconne, ensuite tu choisis l'encodage de caractères que tu souhaites (UTF-8 ou ISO8859-1), puis tu décoches l'option "appliquer par défaut à tous les messages..." et tu cliques sur le bouton "reconstruire l'index".

@+

Xav
Merci pour ta réponse

Cordialement
JCM
Bonjour,
Chez moi, rien de ce qui à été dit ne fonctionne que ce soit l'encodage occidental ISO 8859-1, le 8859-15, ou le UTF-8, avec à chaque fois une reconstruction d'index tout mes courriers ne renvoient que des ??, si quelqu'un à une nouvelle solution, je suis preneur, merci.
Messages postés
49
Date d'inscription
jeudi 29 septembre 2005
Dernière intervention
5 juin 2008
- 30 janv. 2007 à 11:31
1
Merci
Je m'en suis sorti en allant dans "Outils" - "Options" - "Affichage" - "Polices" et en décochant les options "Appliquer le codage..." et "Utiliser le codage...".
Messages postés
17508
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
15 novembre 2018
- 3 mars 2009 à 12:34
1
Merci
aller voir dans outils -> options -> affichage -> formatage -> polices -> encodage des caractères
1
Merci
Pour corriger ce problème d'accent et trouver le bon encodage, j'ai fait : courrier entrant (ou tout autre dossier d'envoi ou de réception), propriétés, changer d’encodage (Unicode (utf-8 dans ce cas) reconstruire l’index, et les emails sont réparés. :)
Messages postés
25778
Date d'inscription
samedi 8 juillet 2006
Statut
Contributeur sécurité
Dernière intervention
4 mars 2010
- 19 oct. 2006 à 10:57
0
Merci
En fait, je ne l'utilise plus, non pas parce que cela fonctionnait mal, mais parce que je trouvais (erreur dirons certains) que cela ne m'apportait rien de plus qu'Outlook Express. Pour le codage, je n'avais rien changé et laissé les options d'origine.
Messages postés
49
Date d'inscription
jeudi 29 septembre 2005
Dernière intervention
5 juin 2008
- 19 oct. 2006 à 11:19
ok, merci de tes renseignements

moi, je l'ai installé en test parce qu'il est bien meilleur filtreur de tous les messages pubs quotidiens qui remplissent nos bals type Rolex pas chère, viagra, et autres produits pharmaceutiques.

Ses filtres et son apprentissage des "indésirables" très simples et intuitifs ce qui n'est pas le cas de outlook et des préférences de la messagerie de mon FAI.
Messages postés
4798
Date d'inscription
mercredi 19 avril 2006
Statut
Contributeur
Dernière intervention
10 juin 2015
- 19 oct. 2006 à 14:09
0
Merci
Bonjour,
Une solution , temporaire , qui peut -être conviendra, c'est d'utiliser ,la table, des caractéres de windows ,et de copier dans thunderbird la lettre voulue. C'est contraignant mais elle peut dépanner..
Cela dit , pour ma part, dans thunderbird, sous affichage-encodage des caractéres -il n'y aucun choix particulier de fait ,(j'ai laissé par défaut)et ça fonctionne ,chez moi.(sauf pour les caractères très spéciaux comme par exemple :Ñ) Le paramétrage ,a-t-il ,été modifié chez vous.
(choix de la police , encodage.. ?)
Pour ce qui est du blocage des mails indésirables , philozof, suis complètement d'accord avec cet avis , a savoir que thunderbird , comme vous l'avez dit gère bien le "pourriel"
a+
Plouf plouf

60% des problèmes informatique se sitent entre le clavier et la chaise;-)
Messages postés
49
Date d'inscription
jeudi 29 septembre 2005
Dernière intervention
5 juin 2008
- 19 oct. 2006 à 17:55
merci de votre avis et conseil, j'essayerai

pouvez-vous me dire quels sont vos paramètres dans thunderbird pour la police et l'encodage tant pour les messages entrants que sortant ?

Merci d'avance
Messages postés
4798
Date d'inscription
mercredi 19 avril 2006
Statut
Contributeur
Dernière intervention
10 juin 2015
- 30 janv. 2007 à 13:01
0
Merci
bonjour,
ok ..contente pour vous..;-)
a bientôtpeut-être :-)
la police que j'ai pris est occidental (ISO 8859-1) courrier entrant & courrier sortant
Bon surf !
a+
Plouf Plouf
Messages postés
4
Date d'inscription
mardi 19 février 2008
Dernière intervention
20 février 2008
- 19 févr. 2008 à 15:51
0
Merci
Hello

J'ai un problème du genre avec thunderbird. j'ai testé plusieurs combinaisons de code et le problème reste le même:

je m'explique : soit la boite de réception est ok mais certaines message ont des caractère bizarre

soit la réception est pas ok mais les messages sont ok

que faire pour que boite de réception et messages soient ok en même temps ?


Thx
Messages postés
4798
Date d'inscription
mercredi 19 avril 2006
Statut
Contributeur
Dernière intervention
10 juin 2015
- 19 févr. 2008 à 16:36
0
Merci
Bonjour Marie 48,
Peux-tu , stp créer , ton propre topic , merci !
(de manière à ce que les postes ,qui sont résolus ,dans un premier temps, restent compréhensibles.)
Bonne journée .
;))
Messages postés
4
Date d'inscription
mardi 19 février 2008
Dernière intervention
20 février 2008
- 19 févr. 2008 à 16:54
0
Merci
ok j'ai fais ca.

bonne soirée
Bonjour avez vous eu une solution car moi depuis peu j'ai des caractères bizarres et je tout asaiyé en cochant et décochant rien à faire

merci si vous avez eu des réponses à ce sujet

Cordialement

Jcmrock