Menu

Excel/fonction si/date [Résolu/Fermé]

Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
- - Dernière réponse : gbinforme
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
- 21 déc. 2011 à 22:48
Bonsoir à toute et tous...

j'ai un petit souci sur lequel je bloc...si qq un pouvait m'éclairer se serait vraiment sympa..

je cherche une solution au problème suivant :

dans la colonne A, j'ai des dates, j'aimerais mettre en C une formule disant :
si la date en A2 est > au 01/07/2011 alors en c2 j'aurais la date du 01/2013 qui s'indique, par contre si la date en A2 est inférieur au 01/07/2011 alors c'est la date du 01/2012 qui s'indique

afin de m'aider à me faire comprendre voici le fichier.. http://cjoint.com/?3LurvYJyRIC

merci de l'aide et l'éclairage que vous pourrez m'apporter.

bien à vous tous,

berni//
Afficher la suite 

5 réponses

Meilleure réponse
1
Merci
Bonjour,

sur mon excel (2000) la condition si n'aime pas les valeurs avec les / mais cela se résoud facilement en prenant les valeurs numériques des dates (sur une date passe en format nombre et tu verras la correspondance.

donc =SI(A2<40725;40909;41275) marche sachant que 01/07/11 =40725, 01/01/2012=40909 et 01/01/13= 41275 (ne pas oublier de passer en format date)

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 38938 internautes nous ont dit merci ce mois-ci

Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
4842
1
Merci
bonjour benji71,

Il ne manque pas grand chose à ta formule pour qu'elle donne le résultat escompté :

=SI(B2<>0;"";SI($A2>DATEVAL("1/7/2011");"01/2013";"1/2012"))


DATEVAL permet à excel de comparer ta date avec la date 1/7/2011.

Ton résultat n'est pas une date mais du texte.

Si tu veux l'utiliser ensuite comme date tu peux le faire ainsi :

=SI(B2<>0;"";SI(A2>DATEVAL("01/07/2011");DATEVAL("1/1/13");DATEVAL("1/1/12")))

en mettant le format personnalisé "m/aaaa"

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 38938 internautes nous ont dit merci ce mois-ci

Messages postés
27
Date d'inscription
mardi 20 décembre 2011
Statut
Membre
Dernière intervention
9 janvier 2012
2
1
Merci
bonjour , jbinforme , je trouve assez riche tes intervention , cependant je voudrais faire une gestion de stock sur excel mais je suis bloqué

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 38938 internautes nous ont dit merci ce mois-ci

gbinforme
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
4842 -
Bonjour ITconst,

Si tu veux un coup de main dans ton projet, crées toi un sujet personnel en exposant précisément ton blocage car ici c'est le sujet de benji71.
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
20
0
Merci
Bonsoir srg2,

je ne connaissais pas ce petit truc du passage du numérique au format date...merci à vous...

tres bonne soirée...

berni///
Messages postés
738
Date d'inscription
samedi 22 mars 2008
Statut
Membre
Dernière intervention
4 janvier 2015
20
0
Merci
Bonsoir à tous,

petit poste pour vous remercier de votre intervention et de votre aide.
des remerciements tt particulier à gbinforme...

bien à vous tous..

berni//
gbinforme
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
4842 -
Bonsoir benji71,

Merci de ton message et bonnes fêtes à toi.