Excel Concaténer date avec heure [Résolu/Fermé]

Signaler
Messages postés
185
Date d'inscription
jeudi 20 septembre 2007
Statut
Membre
Dernière intervention
17 août 2018
-
 AC -
Bonjour,

J'ai une date dans une cellule (A1) au format jj/mm/yyyy donnée pqr la formule aujourdhui()
dans une autre cellule (B1) une heure en hh:mm donnée par la formule maintenant().

Je souhaiterai les concaténer dans une cellule (C1) a l'aide d'une macro au format "jj/mm @ hh:mm".

Aujourd'hui je le fais manuellement ( je réécris la date et l'heure avec un @ entre eles deux).

Est-ce que quelqu'un aurrait une solution pour moi s'il vous plait?

Merci d'avance


7 réponses

Messages postés
7953
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
19 février 2020
1 295
Ou bien :
=TEXTE(A1 + A2;"jj/mm/aaaa"" @ "" hh:mm")
7
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 87666 internautes nous ont dit merci ce mois-ci

Merci ça m'a aidé
Messages postés
185
Date d'inscription
jeudi 20 septembre 2007
Statut
Membre
Dernière intervention
17 août 2018
5
Merci,

J'ai un autre probleme tout a fait similaire puisque je dois concaténer un date format dd/mm/yyyy et une heure hh:mm en dd/mm @ hh:mm.

A1: date
A2: heure
A3: date @ heure

Merci d'avance
Messages postés
185
Date d'inscription
jeudi 20 septembre 2007
Statut
Membre
Dernière intervention
17 août 2018
5
J'ai enfin trouvé une solution je ne sais pas si c'est tres élégant mais ca marche. il faut déclarer les variables en tant que string.

Dim dt,hr as String

dt = Cells(1, 1)
dt = Format(dt, "DD/MM")
hr = Cells(2, 1)
hr = Format(hr, "HH:MM")

Cells(3, 1)= dt & " @ " & hr


Merci pour votre aide
Patrice33740
Messages postés
7953
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
19 février 2020
1 295
« il faut déclarer les variables en tant que string.
Dim dt,hr as String »

déclare hr comme string et dt comme variant, pour déclarer les deux comme string, il faut écrire :
Dim dt as String,hr as String
Mrfrize
Messages postés
185
Date d'inscription
jeudi 20 septembre 2007
Statut
Membre
Dernière intervention
17 août 2018
5
Ok merci
Messages postés
7953
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
19 février 2020
1 295
Inutile de concaténer, MAINTENANT() fournit directement la date et l'heure, pour le visualiser, il suffit d'utiliser le format (français) : jj/mm/aaaa hh:mm
Patrice33740
Messages postés
7953
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
19 février 2020
1 295
et si tu tiens à l'@ entre les deux tu peux utiliser le format :
jj/mm/aaaa "@" hh:mm
Patrice33740
Messages postés
7953
Date d'inscription
dimanche 13 juin 2010
Statut
Membre
Dernière intervention
19 février 2020
1 295
sous forme de texte :
=TEXTE(MAINTENANT();"jj/mm/aa ""@"" hh:mm")
Messages postés
24888
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
20 février 2020
5 039
Bonjour
peut être ceci
=TEXTE(A1&A2;"jj/mm/aaaa"" @ "" hh:mm")
sur le principe que Patrice nous avait indiqué.
tout simplement
crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?
Messages postés
185
Date d'inscription
jeudi 20 septembre 2007
Statut
Membre
Dernière intervention
17 août 2018
5
J'ai reussi a faire ca :

Dim dt,hr as Date

dt = Cells(1, 1)
dt = Format(dt, "DD/MM")
hr = Cells(2, 1)
hr = Format(hr, "HH:MM")

Cells(3, 1)= dt & " @ " & hr
Cells(4, 1) = hr => juste pour tester.

Et j'ai encore un probleme la date ce met bien au format dd/mm mais l'heure ce mets toujours en hh:mm:ss et je ne sais pas pourquoi.
Je dirai meme que dans la cellule A4 j'ai un format hh:mm:ss AM/PM alors que j'aimerai bien en 24 heures.
Dans la cellule A2 pourtant mon format est en hh:mm en 24H

Quelqu'un aurais une idée?

Merci
Messages postés
185
Date d'inscription
jeudi 20 septembre 2007
Statut
Membre
Dernière intervention
17 août 2018
5
Bonjour vos solutions marche surment mais ce sont des formules Excel, moi je souhaite le faire par une macro. Qui sera intégré a une autre qui fait d'autre chose.

Merci d'avance