Menu

Pb pour calculer un temps de travail [Résolu/Fermé]

Messages postés
2
Date d'inscription
mardi 22 novembre 2011
Statut
Membre
Dernière intervention
22 novembre 2011
- - Dernière réponse : sanfroiniloi
Messages postés
15
Date d'inscription
dimanche 22 janvier 2012
Statut
Membre
Dernière intervention
28 novembre 2016
- 1 oct. 2014 à 18:57
Bonjour à tous,

Je suis entrain de calculer des temps de travail (qui peuvent être à cheval sur 2 jours).

J'ai utiliser une formule du type : =SI(B1<A1;(24-A1)+B1;B1-A1)
Elle me donne entière satisfaction!

Je veux ensuite convertir ces durées en heures centièmes au lieu de heures minutes, donc si j'ai 08:30, j'obtiens 8,5.
Pour se faire je passe ma cellule en nombre et je multiplie par 24

SAUF que pour les durées correspondant au calcul (24-A1)+B1 et bien ca ne marche pas :-(

En espérant que quelqu'un puisse m'aider.
Merci d'avance à tous
Afficher la suite 

4 réponses

Meilleure réponse
Messages postés
15
Date d'inscription
dimanche 22 janvier 2012
Statut
Membre
Dernière intervention
28 novembre 2016
51
7
Merci
Bonsoir,

vous pouvez également aller voir ici, çà fonctionne très bien.

http://fr.pichard.free.fr/ic_calc/

Dire « Merci » 7

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 39166 internautes nous ont dit merci ce mois-ci

Messages postés
22734
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 mai 2019
5476
1
Merci
Bonsoir,

en C1 :
=MOD(B1-A1;1)
en D1 :
=C1*24 ou directement =MOD(B1-A1;1)*24

eric
Messages postés
2
Date d'inscription
mardi 22 novembre 2011
Statut
Membre
Dernière intervention
22 novembre 2011
0
Merci
Petit exemple sans les formules :

21:00 5:24 8:24 560,40 FAUX
. 8:24 8,40 BON
18:00 1:00 7:00 559,00 FAUX
10:00 17:00 7:00 7,00 BON
0
Merci
Merci beaucoup pour votre aide !