Excel recherchev intervalle [Fermé]

Messages postés
107
Date d'inscription
mercredi 16 avril 2008
Statut
Membre
Dernière intervention
1 janvier 2013
-
Bonjour, j'ai un problème de formules dans excel.

J'ai un tableau sous cette forme

Les données:

N° Valeur Prix
1 - 0 à 0,5 - 10
2 - 0,5 à 1 - 15
3 - 1 à 2 - 20
4 - 2 à 5 - 25

L'application:

N° Valeur Prix
1 - 0,4 - 10
2 - 0,9 -15
3 - 1,5 - 20
4 - 4 - 25

Je rentre la "valeur" manuellement et je veux que le prix s'affiche automatiquement. J'ai fait une RECHERCHEV, si je rentre un chiffre rond, comme 0,5 ça marche mais si je note par exemple 0,4 ça ne marche pas. Comment noter une intervalle dans une recherche? Dans les données ?

Merci




Le problème dans les maths, c'est le français.
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
24653
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 novembre 2019
4877
5
Merci
Bonjour

RECHERCHEV devrait fonctionner
_si votre colonne Valeur comporte un seul nombre, limite inférieure de l'intervalle
_si votre colonne de recherche est classé en ordre croissant.
_si vous n'insérer pas de code "obligatoire" en fin de formule:

par exemple:
en colonne A:
A1:0
A2:0,5
A3:1 etc>....
en B les prix en ligne

=RECHERCHEV(valeur;A:B;2.2)
(sans 0 ou faux à la fin)
Formulé comme ceci la fonction vous ressort la valeur de B en ligne avec la 1° valeur directement inférieure de A
Crdlmnt

Dire « Merci » 5

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 71533 internautes nous ont dit merci ce mois-ci

Messages postés
50273
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
8 novembre 2019
11133
0
Merci
Bonjour.

Ton tableau se limite à 4 lignes ?
Dans quelles cellules se trouvent : les intervalles, les prix, la valeur testée ?
Qu'est-ce que tu as écrit comme formule, et dans quelle cellule ?
La borne 1 se trouve incluse dans l'intervalle 2 ou 3 ?
Messages postés
24653
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 novembre 2019
4877
0
Merci
suite du précédent:
si vous voulez conserver l"écriture telle que votre message soit:
0 à 0,5
0,5 à 1
1 à 1,5
etc
essayez ceci:
colonne A la liste des limites selon le format ci dessus
en B la liste des prix
en colonne Z qui pourra être masquée, la formule:
=STXT(A2;TROUVE("à";A2;1)+2;10)*1
à tirer sur la hauteur du tableau
Placer 0 en Z1 pour débuter la liste
il faut que la liste commence par 0

vous pouvez ensuite appliquer la formule:
=INDEX(B:B;EQUIV(valeur;Z:Z))

à noter que pour suivre la remarque judicieuse de notre ami Raymond, (étant donné que vous avez à chaque ligne en A la même valeur en maxi que celle du mini suivant)ces solutions considèrent que lorsqu'une valeur limite exacte est cherchée, c'est l'inférieure qui est trouvée

crdlmnt

Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?