Calcul de moyenne si [Résolu/Fermé]

Messages postés
11
Date d'inscription
dimanche 22 février 2009
Statut
Membre
Dernière intervention
29 décembre 2013
-
Bonjour,
je dispose d'un fichier excel avec un onglet où se situe mes données et je souhaite insérer un onglet pour y synthétiser quelques informations (sans forcément passer par un tableau croisé dynamique).
Dans cet autre onglet je souhaite calculer une moyenne d'âge par genre (ex homme/femme).
J'ai pensé à une moyenne si mais je bute sur la construction.
Pourriez vous m'éclairer ?
En vous remerciant.


Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
1270
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
495
1
Merci
Bonjour,

Avec le genre en colonne B et l'âge en colonne A :
=SOMMEPROD((B2:B18="homme")*(A2:A18))/SOMMEPROD((B2:B18="homme")*1)

Et tu remplace homme par femme ou par la référence d'une cellule.

Bonne soirée.

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 58822 internautes nous ont dit merci ce mois-ci

Messages postés
24291
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 août 2019
4721
1
Merci
Bonjour

avec MOYENNE.SI:
=MOYENNE.SI(champ sexe;"type sexe";champ valeur)
tout simplement
champ sexe: champ où est indiqué le sexe
type sexe: entre guillemets, le code qui définit homme ou femme, ou, sans les guillemets, l'adresse d'une cellule où ce code sera entré
champ valeur: champ des nombres pour le calcul.
Bonne chance
c rdlmnt

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 58822 internautes nous ont dit merci ce mois-ci

Messages postés
11
Date d'inscription
dimanche 22 février 2009
Statut
Membre
Dernière intervention
29 décembre 2013
0
Merci
Merci beaucoup pour votre aide.
Ça fonctionne.