Menu

Sata en ntfs non reconnu sous mandriva [Résolu/Fermé]

- - Dernière réponse : mamiemando
Messages postés
28645
Date d'inscription
jeudi 12 mai 2005
Statut
Contributeur
Dernière intervention
8 décembre 2018
- 15 août 2006 à 21:15
Bonjour,
J'ai installer Linux Mandriva 2006 il y a peu sur mon pc en cohabitation avec XP.
Tout fonctionne correctement mais le seul probleme est que mon deuxieme disque dur Maxtor 120 Go en SATA n'apparait pas sous linux alors qu'il fonctionne a merveille sous XP.
Je voudrais savoir s'il etait possible de remedier ce probleme sans forcement formater mon Dur et ainsi tout perdre pour que je puisse m'en servir avec linux.
Merci de vos reponses.
Bon courage a tous. Et vive la musique de TOULOUSE.
Afficher la suite 

6 réponses

Messages postés
43479
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
17 mars 2018
0
Merci
Salut,

Peux-tu nous poster le résultat des commandes suivantes, s'il te plaît (en root) :
/sbin/fdisk -l
cat /etc/fstab
dmesg | grep -i SATA
;-))
Messages postés
28645
Date d'inscription
jeudi 12 mai 2005
Statut
Contributeur
Dernière intervention
8 décembre 2018
0
Merci
1) La première étape c'est de voir si le disque SATA est reconnu. Pour celà il faut vérifier que tu as un device genre /dev/sda ou /dev/sdb etc.... Exemple :
ls /dev/sd*

Si rien n'apparaît, inutile de continuer ton noyau ne prend pas en charge ton disque SATA. Tente à tout hasard :
cd /dev ; ./MAKEDEV

... et regarde si du coup le device apparaît. Si ça ne change rien, inutile de continuer ton noyau ne prend pas en charge ton disque. Il faut en mettre un plus récent ou en compiler un avec le support SATA.

2) Si le périphérique apparaît (par exemple /dev/sda), examine la table des partitions pour vérifier si c'est bien le disque SATA. En root :
/sbin/cfdisk /dev/sda

Si c'est le bon disque il faut alors le monter. Note le nom de la partition par exemple /dev/sda1.

3) Pour que celà soit possible outre la création du point de montage il faut que ton noyau prenne en charge la NTFS. C'est en général le cas. rajoute (adapte au besoin) la ligne suivante dans /etc/fstab, en root :
/dev/sda1  /mnt/ntfs    ntfs   user,users,ro,exec,auto   0  0

Ensuite tape en root :
mkdir -p /mnt/ntfs

La partition sera montée au prochain démarrage, mais tu peux d'ores et déjà la monter en tapant dans une console utilisateur :
mount /mnt/ntfs

Bonne chance
0
Merci
Merci a tous pour tout.
J'essaye ca ce soir.
Je garde espoir,j'ai confience.

Merci pour le soutien quand meme.
Je ne pense pas que pour windows, ca aurait ete aussi rapide!!
Messages postés
17
Date d'inscription
vendredi 11 août 2006
Dernière intervention
11 décembre 2008
0
Merci
Merci beaucoup encore.
Ca marche !!
A une prochaine fois sur un autre topic.
Messages postés
17
Date d'inscription
vendredi 11 août 2006
Dernière intervention
11 décembre 2008
0
Merci
Non en fait j'ai un autre petit soucis,
voila j'arrive a acceder a mon dur mais seulument en me connectant en root.
Quand j'ouvre ma session il me dit que je n'ai pas les droits suffisants.
Seulement quand j'essaye de changer ces droits en root,
il refuse.
Comment faire ?
Merci
Messages postés
28645
Date d'inscription
jeudi 12 mai 2005
Statut
Contributeur
Dernière intervention
8 décembre 2018
0
Merci
Tu n'as pas mis dans /etc/fstab les options user et users. Cf réponses précédentes. Tu peux spécifier l'uid et le gid dans ce même fichier, en accord avec les fichiers /etc/groups et /etc/passwd :

/dev/sda1  /mnt/ntfs    ntfs   user,users,ro,exec,auto,uid=mando,gid=tapir   0  0


Bonne chance