Problème d'input type button XHTML [Résolu/Fermé]

Messages postés
139
Date d'inscription
dimanche 23 décembre 2007
Statut
Membre
Dernière intervention
12 janvier 2014
- - Dernière réponse : mat_elot
Messages postés
139
Date d'inscription
dimanche 23 décembre 2007
Statut
Membre
Dernière intervention
12 janvier 2014
- 10 oct. 2011 à 15:31
Bonjour,
J'ai un souci, j'ai rajouté la ligne suivant dans mon fichier:

<quote>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr">
</quote>

et sa présence fait rendre mon button impuissant sous firefox alors que ca marche nickel sous IE (une fois n'est pas coutume c'est firefox qui fait chier).

Est ce que quelqu'un aurait une idée du pourquoi du comment??

MErci beaucoup!



Afficher la suite 

2 réponses

Messages postés
212
Date d'inscription
lundi 19 septembre 2011
Statut
Membre
Dernière intervention
9 avril 2014
43
0
Merci
Quel bouton ?
Et pourquoi entourer le doctype et la balise html de balise quote ??
mat_elot
Messages postés
139
Date d'inscription
dimanche 23 décembre 2007
Statut
Membre
Dernière intervention
12 janvier 2014
22 -
les balises quote je croyais que ça mettrais une mise en page spéciale pour mettre mon code ;)
Messages postés
3485
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
14 octobre 2019
915
0
Merci
Bonjour,

As-tu essayé de passer ta page au valideur W3C ?
http://validator.w3.org/unicorn/

Xavier
mat_elot
Messages postés
139
Date d'inscription
dimanche 23 décembre 2007
Statut
Membre
Dernière intervention
12 janvier 2014
22 -
ca passe pas car j'ai plein d'erreur du à du CSS spécifique pour IE..
Mon souci venait d'un code JS qui mettait le bordel.
Merci quand meme!
Mathieu