Recherche une formule sur Excell [Résolu/Fermé]

- - Dernière réponse :  nanou - 29 août 2011 à 12:08
Bonjour,



Je cherche à additionner les nombres de la colonne C, si (ou quand) les codes de la colonne A sont identiques.

Est ce que quelqu'un peut m'aider ?...

merci
Afficher la suite 

6 réponses

Meilleure réponse
Messages postés
24587
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 octobre 2019
4831
1
Merci
Re
à défaut de comprendre, essayez ceci:
en D1 une formule à tirer sur la hauteur du champ:
=SI(NB.SI(A:A;A1)=NB.SI($A$1:A1;A1);SOMME.SI(A:A;A1;C:C);"")
elle vous donnera le cumul de C pour chacun des codes identiques, en face de la dernière apparition du code dans la liste et sur cette ligne seulement.
attention aux positions des signes $

Crdlmnt
Demandons nous si nous ne sommes pas seuls à comprendre ce que l'on explique?

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63775 internautes nous ont dit merci ce mois-ci

Super! J'ai adapté et ca marche impec ! C'est exctement ca que je cherchais!
cela m'évite de nombreuses manipulations et un gain de temps précieux. : )

merci pour votre aide précieuse car je ne l'aurais jamais trouvé toute seule celle-ci.

Bonne journée
Messages postés
15934
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 octobre 2019
2811
0
Merci
Bonjour
si (ou quand) les codes de la colonne A sont identiques.

identiques à quoi?
En fait dans ma colonne A j'ai une liste de codes qui identifie un produit. Je cherche à identifier les codes redondants et dans ce cas à additionner leur volumes (en colonne C).

Espérant avoir éclaircie ma question...
0
Merci
salut,


Utilise la fonction somme.si

Si j'ai bien compris ta question, la syntaxe est la suivante :
=SOMME.SI(A2:A9;"=critère";C2:C9)
la 1ère partie concerne la plage sur laquelle tu fais la vérification (colonne A dans ton cas).
La 2ème concerne le critère à proprement parler ("=pommes", ">200", ...).
La 3ème partie concerne la plage à sommer, donc la colonne C dans ton cas.

voilà, j'espère que ça peut t'aider.
oui mais là mon critère est "un code (suite numérique) " inscrit dans les cellules de la colonne A. Lorsque c'est le même, additionne.

Espérant avoir été plus précise.

merci pour ton aide
Vaucluse
Messages postés
24587
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
17 octobre 2019
4831 -
bonjour
la solution d'andy est bonne, mais:
si le code est numérique, ne pas le mettre entre guillemets

ex pour un code 30456
=SOMME.SI(A2:A9;30456;C2:C9)

si le code est un texte, ne pas mettre le signe =
=SOMME.SI(A2:A9;critère;C2:C9)

enfin, pour régler tous les problèmes, on peut utiliser une cellule pour lacer le code cherché
=SOMME.SI(A2:A9;D1;C2:C9)
et entrer dans la cellule D1 le code cherché.

crdlmnt
Messages postés
15934
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
16 octobre 2019
2811
0
Merci
re ou bonjour (suivant l'heure d'arrivée)

La solution sans se prendre la t^te avec des formules serait d'utiliser un tableau croisé dynamique: 5 minutes de boulot...
0
Merci
Merci à tous pour votre aide et réactivité.
-2
Merci
j'ai pas bien compris. tu peux donner un exemple stp.
pourquoi tu peux pas dire comme critère "=ton code" ? tu dois mettre le critère entre guillemets, sinon il comprend pas. J'ai aussi déjà essayé de faire une formule avec un critère variable (référence à une cellule), mais j'avais pas réussi... tu peux essayer de compiler la fonction indirect.