EXCEL : rechercher info dans une autre feuill [Résolu/Fermé]

Signaler
-
chossette9
Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
-
Bonjour,

Je travaille actuellement sur un fichier où je cherche des infos dans une feuille Y du classeur pour les mettre dans la feuille X. Ma feuille Y possède une colonne A avec des noms d'entreprise et ma colonne B leurs adresses. J'ai un menu déroulant dans ma feuille X où je sélectionne le nom de l'entreprise dans une cellule C1 et l'adresse s'affiche automatiquement dans la cellule D1 grace à cette formule :
=SI(ESTNA(RECHERCHEV(H6;Entreprises!A2:B236;2;FAUX));"Non désignée";RECHERCHEV(H6;Entreprises!A2:B236;2;FAUX))

Ma question est la suivante : j'aimerai ajouter des colonnes à mon fichier de base (C avec un nom et D avec un numéro de téléphone par exemple) et lorsque je séléctionne une entreprise leur numéro s'affiche dans ma cellule E1 de la feuille X.
J'avais donc penser utiliser la même formule mais en changeant simplement B en D pour qu'il cherche dans la colonne des numéros. Seulement, ceci ne fonctionne pas.

Je vous avouerai être novice et essayer de me débrouiller comme je peux, donc j'ai du mal à trouver mon erreur. Si vous pouviez m'aiguiller un petit peu, merci d'avance.

MargoOw
Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1161
Bonjour,

si tu ajoutes des colonnes à tes données de bases, il faudra effectivement modifier dans tes formules de recherche la matrice sur laquelle se basera cette recherche (A2:B236 deviendra A2:D236) dans ton cas.

Si tu souhaites récupérer le numéro, qui se trouve en colonne D, il te faudra remplacer le 2 du troisième critère par 4, vu que dans ta matrice, les numéros de téléphone se trouvent en 4e colonne.

Ta formule sera donc :
SI(ESTNA(RECHERCHEV(H6;Entreprises!A2:D236;4;FAUX));"Non désignée";RECHERCHEV(H6;Entreprises!A2:D236;4;FAUX)) 


Cordialement.
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63142 internautes nous ont dit merci ce mois-ci

Quelle idiote ! C'était sous mes yeux !
Cela fonctionne à merveilles, merci & bonne journée.
chossette9
Messages postés
4428
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1161
Mais de rien ^^

Souvent ce sont les solutions les plus simples que l'on ne voit pas.

bonne journée à toi aussi.