Lecture mp3 (KDE) a partir d'un serveur [Fermé]

Signaler
Messages postés
953
Date d'inscription
mardi 24 novembre 2009
Statut
Membre
Dernière intervention
18 mars 2013
-
mamiemando
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
-
Bonjour,

J'essais de m'habituer a KDE avec Kubuntu, car je commence a être alaise avec apt-get et tous ca ! Et j'ai eu le même probleme avec Fedora et KDE, donc je pense que le probleme vien simplement de l'environnement ! Je veut juste lire ma musique avec audacious qui vient d'un serveur de fichier, donc un seul mp3 ca va, mais lorsque j'en mets plusieurs, il est impossible de les lirent ! On dirais que KDE ne gère qu'une seul tache a la fois !
Quelqu'un a une solution SVP !

Merci !



8 réponses

Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 808
Hum euh tu as sûrement tes raisons mais pourquoi ne pas simplement utiliser amarok ?

Et pour qu'on fasse des tests, peux-tu nous indiquer l'adresse du serveur de fichiers (sous réserve évidemment que son accès soit public et non compromettant !!).

Bonne chance
Messages postés
953
Date d'inscription
mardi 24 novembre 2009
Statut
Membre
Dernière intervention
18 mars 2013
124
C'est un serveur de fichier local qui est visible a partir de samba simplement ! Bizarre avec Gnome, je n'ai pas se probleme ! J'utilise audacious pour son look Winamp ! En gros, j'accede au pc partager, j'ouvre mon dossier musique et je glisse les mp3 dans la liste du lecteur ! Lorsque je glisse un seul MP3, la notification exécute 1 tâche et la lecture se fais, mais a plusieur fichier mp3, rien ne se passe et la lecture est impossible !
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 808
Hum je comprends ton soucis. Bon malheureusement ma réponse est pas tip top car en gros :
1) je t'invite à passer à amarok qui est mieux :p
2) au pire tu peux utiliser le logiciel gnome sous kde :p

Tu peux aussi regarder du côté de xmms qui ressemble trait pour trait à audacious puisque c'est un fork...

Je ne sais pas trop quoi te dire de plus je ne connais pas audacious plus que ça. Mais dans l'idée, si tu as monté ton partage samba par exemple dans /mnt/samba, cette musique devrait être accessible au même titre que n'importe quelle musique stockée en local...

Bonne chance
Messages postés
953
Date d'inscription
mardi 24 novembre 2009
Statut
Membre
Dernière intervention
18 mars 2013
124
Le probleme semble venir de la gestion interne avec lequel KDE fonctionne parceque, peut importe avec quel lecteur je lis mes MP3, l'ajout de mp3 a partir d'un dossier partager a partir d'un autre pc est impossible a lire ! Il saute sans cesse de piste en piste comme c'est le cas ou le fichier est innacessible et tente de passer a un autre piste !
Bref, je suis revenu a mon bon vieux LinuxMint !
Je laisse le post ouvert, on sais jamais, peut-etre quelqu'un aura une solution !
Merci !
Messages postés
14745
Date d'inscription
samedi 9 décembre 2006
Statut
Contributeur
Dernière intervention
17 décembre 2019
2 061
bonjour,
quel est ton dossier de montage ?
j'ai remarque qu'avec samba , il aimait bien un dossier public dans le /home a l'inverse de nfs qui lui du moins c'est mon expérience n'aime pas trop les dossier dans /home .
d'ailleurs kde créer depuis la version 4 un dossier /home/user/Public
a+
FC 13 - Mandriva 2010 -Debian squeeze-
Les meilleures choses ont besoin de patience.(JC ANGLADE)
penser aux astuces
FreakOut
Messages postés
953
Date d'inscription
mardi 24 novembre 2009
Statut
Membre
Dernière intervention
18 mars 2013
124
Je ne serais te dire ! J'accede au partage windows 7 avec Kubuntu ! (j'ai eu le meme probleme avec Fedora 15 KDE)
Je suis passer par le bureau directement, comme d'habitude, je créé un lanceur en mettant un nom et le chemin pour y accédé ( smb://192.168.X.X/ ) et je fais créé ! Sous gnome, le montage se créé directement sur le bureau, mais avec kde, je sais pas ou il se trouve ! C'est domage car c'est pourtant tout con !
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 808
1) De la part de jeanbi (ses messages sont passés à la corbeille à cause d'une règle de filtrage abusive)

re,
sous kde c'est pas auto donc le plus simple tu ouvres dolphin tu clic droit sur le dossier /home/user/Public et tu clic sur partage et tu creer ton partage samba
a+


2) Est-ce que le passage sur les différentes pistes se produit également quand tu rappatries les musiques par exemple dans ton home directory ? Car vu les symptômes, ça ressemble plus à un greffon mp3 mal installé :

sudo aptitude update
sudo aptitude install libxine1-ffmpeg


3) Par ailleurs, comment accèdes tu as ton partage samba ? Est ce qu'il est correctement monté par exemple dans /mnt/samba ? Est ce que tu as les droits pour lire ces fichiers ?

Dans le doute reporte-moi le résultat de :

mount


... et en admettant que ta musique soit dans /mnt/samba/musique :

ls -l /mnt/musique/samba


Bonne chance
Messages postés
953
Date d'inscription
mardi 24 novembre 2009
Statut
Membre
Dernière intervention
18 mars 2013
124
Jai le meme probleme sous fedora 15 avec gnome 3 !
quand je tape mount:

-------------------------------------------------------------------------------------------------------------------
/proc on /proc type proc (rw,relatime)
/sys on /sys type sysfs (rw,relatime,seclabel)
udev on /dev type devtmpfs (rw,nosuid,relatime,seclabel,size=1024104k,nr_inodes=213571,mode=755)
devpts on /dev/pts type devpts (rw,relatime,seclabel,gid=5,mode=620,ptmxmode=000)
tmpfs on /dev/shm type tmpfs (rw,relatime,seclabel)
tmpfs on /run type tmpfs (rw,nosuid,nodev,noexec,relatime,seclabel,mode=755)
/dev/mapper/vg_gfeatlinux-lv_root on / type ext4 (rw,relatime,seclabel,user_xattr,barrier=1,data=ordered)
selinuxfs on /selinux type selinuxfs (rw,relatime)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,relatime,seclabel,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/cpu type cgroup (rw,nosuid,nodev,noexec,relatime,cpu)
cgroup on /sys/fs/cgroup/cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpuacct)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/net_cls type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
systemd-1 on /sys/kernel/debug type autofs (rw,relatime,fd=28,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /sys/kernel/security type autofs (rw,relatime,fd=29,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /dev/hugepages type autofs (rw,relatime,fd=30,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=31,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
systemd-1 on /dev/mqueue type autofs (rw,relatime,fd=32,pgrp=1,timeout=300,minproto=5,maxproto=5,direct)
tmpfs on /media type tmpfs (rw,nosuid,nodev,noexec,relatime,rootcontext=system_u:object_r:mnt_t:s0,seclabel,mode=755)
/dev/sda1 on /boot type ext4 (rw,relatime,seclabel,user_xattr,barrier=1,data=ordered)
/dev/mapper/vg_gfeatlinux-lv_root on /tmp type ext4 (rw,relatime,seclabel,user_xattr,barrier=1,data=ordered)
/dev/mapper/vg_gfeatlinux-lv_root on /var/tmp type ext4 (rw,relatime,seclabel,user_xattr,barrier=1,data=ordered)
/dev/mapper/vg_gfeatlinux-lv_root on /home type ext4 (rw,relatime,seclabel,user_xattr,barrier=1,data=ordered)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
gvfs-fuse-daemon on /home/gfeat/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,relatime,user_id=500,group_id=500)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)

-------------------------------------------------------------------------------------------------------------------

et dans mnt il y a rien !

Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 808
Ben s'il n'y a rien dans /mnt et que tu as défini une règle dans /etc/fstab pour monter un dossier via samba ou nfs c'est un peu normal, non ?

Que donne :

cat /etc/fstab


Que veux-tu monter et dans quel répertoire ?

Bonne chance