Gentoo et paquet masqué [Fermé]

Signaler
Messages postés
121
Date d'inscription
lundi 31 octobre 2005
Statut
Membre
Dernière intervention
9 avril 2007
-
mamiemando
Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
-
bonjour a tous !

bon, voila, j’ai passé si on peut dire le cap pour utiliser gentoo ou plus présisement kororaa car l’install de gentoo avec le live cd foire.

je souhaite la mettre a jour, mais je galere avec certain paquet masqué et surtout celui-la :">=media-libs/glitz-0.5.4_alpha1, il revient meme si je fait un " echo ">=media-libs/glitz-0.5.4_alpha1 x86" >> /etc/portage/package.keywords"

comment résoudre le probleme ? car j’ai vu que c’était une dependance de x11-base/xgl-0.0.1_p20060401 mais xgl en dure ne marche pas, et je cherche pas a le faire marcher pour le momment.

merci

3 réponses

Messages postés
29238
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
27 mars 2020
6 805
Laisse il a dû se gourrer de post ^^
En fait tout est là :
https://wiki.gentoo.org/wiki/Handbook:X86?part=3&chap=3

Pour demasquer un paquet :

Utiliser des paquets masqués

Le fichier package.unmask

Les développeurs Gentoo ne fournissent aucun support pour ces fichiers. Faites très attention quand vous les utilisez. Les demandes de support concernant package.unmask et/ou package.mask ne seront pas considérées. Vous aurez été prévenu.

Si un paquet a été masqué par les développeurs Gentoo et que vous voulez l'installer malgré les raisons précisées dans le fichier package.mask (par défaut dans le répertoire /usr/portage/profiles), ajoutez exactement la même ligne dans le fichier /etc/portage/package.unmask.

Par exemple, si =net-mail/hotwayd-0.8 a été masqué, vous pouvez le rendre disponible en ajoutant la même ligne dans package.unmask

Pour empecher la mise à jour d'un paquet

Le fichier package.mask

Si vous voulez empêcher Portage d'installer un paquet ou une version particulière d'un paquet, vous pouvez ajouter son nom dans le fichier /etc/portage/package.mask.

Par exemple, pour empêcher Portage d'installer des sources de noyaux plus récentes que gentoo-sources-2.6.8.1, ajoutez la ligne suivante dans package.mask :

Exemple de code 5 : Exemple de /etc/portage/package.mask

>sys-kernel/gentoo-sources-2.6.8.1


Bonne chance
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 72002 internautes nous ont dit merci ce mois-ci

Messages postés
5400
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
29 mars 2020
864
Salut,

Je n'y connais rien à Gentoo... Donc, ne prête aucune attention à mon message*... Surtout au Post-scriptum.

C'est étonnant ce concept de "paquet masqué". Celà change-t-il quelque chose si tu le "démasques" ?

http://fr.gentoo-wiki.com/HOWTO_Utiliser_correctement_un_portage#Paquets_masqu.C3...

Il y a cette discussion aussi :

https://linuxfr.org/users/gilren/journaux/xfce4-et-gentoo

A défaut, peut-être que le reste du contenu de ces pages pourra t'aider :)

Un adepte de Gentoo pourrait certainement mieux te renseigner (à moins que tu décides d'installer FreeBSD à la place, dont le système de ports est plus ma tasse de thé :P).


Dal
*en plus je suis fatigué, j'ai chaud et c'est Vendredi
PS : Sinon mon premier réflexe était de penser, à première vue, que celà devait être la VPM ou le RVFPM II (si ce n'est pas la première fois que celà se produit)
[Dal]
Messages postés
5400
Date d'inscription
mercredi 15 septembre 2004
Statut
Contributeur
Dernière intervention
29 mars 2020
864
Sur le lien du Wiki ci-dessusn il y a aussi çà :

http://fr.gentoo-wiki.com/HOWTO_Utiliser_correctement_un_portage#Mise_.C3.A0_jour...

et la section précédente à propos de "world"


Dal
PS : je peux aussi te donner des détails sur mon Post-scriptum, si tu insistes (mais je t'aurais prévenu :D).
hyro
Messages postés
121
Date d'inscription
lundi 31 octobre 2005
Statut
Membre
Dernière intervention
9 avril 2007
11
merci pour les réponse! je suis deja aller sur ces liens, mais je n'ai pas trouvé mon bonheur car il n'y a que ce paquet que ne veux pas etre masqué dans portage.

et oui cela change quelque chose si je le démasque, le paquet ou la dépendance serat installé en dépis du fait que ce sont des paquets instables.

sinon, BSD m'interesse mais est-ce quand meme adapté pour de l'usage "familiale" ou est-ce encore reservé a du serveur ou autre truc de se genre.
car en fait la gentoo que j'ai est une cororaa car la gentoo foire a l'install
Messages postés
4629
Date d'inscription
jeudi 23 octobre 2003
Statut
Contributeur
Dernière intervention
23 août 2019
373
Bonsoir,

J'ai résolu le problème et il est indiqué Statut : En cours .

Je confirme le PROBLÈME RÉSOLU ;-)
hyro
Messages postés
121
Date d'inscription
lundi 31 octobre 2005
Statut
Membre
Dernière intervention
9 avril 2007
11
?