Menu

RechercheV plusieurs valeurs sous Excel [Résolu/Fermé]

Messages postés
15
Date d'inscription
vendredi 6 mai 2011
Dernière intervention
17 janvier 2013
- - Dernière réponse : Geoblog06
Messages postés
1
Date d'inscription
dimanche 3 février 2019
Dernière intervention
3 février 2019
- 3 févr. 2019 à 15:54
Bonjour a tous,

Je suis au bord de la crise sous Excel!
Je n'arrive pas à faire une recherche V sur plusieurs valeurs.
Ma table de donnée est (exemple) :

Feuille 1

-----A----B
1---521---Ok
2---522---PB
3---569---PV
4---569---PJ
5---569---PK

Feuille 2

-----A--------B
1
2
3
4
5
En A1 je mets ma valeur recherche
En B1 je mets la fonction :=RECHERCHEV($A$1;Feuille1!A1:B5;3)

Si je fais une recherché V sur A1= 521 c'est ok il me sort en B1 la valeur Ok
Si je fais une recherche V sur A1= 569 il me sort en B1 seulement la valeur PV alors que je voudrais PV et PJ et PK....

Qui peut m'aider ???

Merci d'avance



Afficher la suite 

3 réponses

Meilleure réponse
approuvée par Jean-François Pillou le 12 déc. 2018
Messages postés
15669
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
13 février 2019
3604
74
Merci
Bonsoir,

Tant qu'on peut se passer tranquillement de VBA....

https://mon-partage.fr/f/WKLLQFnd/

Dire « Merci » 74

Heureux de vous avoir aidé ! Vous nous appréciez ? Donnez votre avis sur nous ! Evaluez CommentCaMarche

CCM 58868 internautes nous ont dit merci ce mois-ci

michel_m
Messages postés
15669
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
13 février 2019
3604 > Pop -
Bonjour,

Puis-je me permettre de vous demander la réactivation du lien j'ai exactement le même problème ?

Cordialement
michel_m
Messages postés
15669
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
13 février 2019
3604 > LauraG -
Voir post 173
Bonjour Michel_m,

Merci pour votre aide précieuse.
Geoblog06
Messages postés
1
Date d'inscription
dimanche 3 février 2019
Dernière intervention
3 février 2019
-
Bonjour Michel_m,
Je vous remercie pour les solutions proposées et j'ai retenue la formule matricielle pour mon tableau.
Je souhaite toutefois réinitialiser la liste à chaque ligne de mon tableau.

Je vous remercie par avance de votre aide

www.grosfichiers.com/BOEnEfBw9FgSw
1
Merci
Bonjour,

J'ai aussi le même problème est-il possible de réuploader le fichier SVP ?
merci beaucoup
michel_m
Messages postés
15669
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
13 février 2019
3604 -
santchev
Messages postés
7
Date d'inscription
dimanche 21 avril 2013
Dernière intervention
8 janvier 2015
-
merci Michel,

bien à toi!
Il dure pas long le lien :(
C'est possible de le remettre..?
michel_m
Messages postés
15669
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
13 février 2019
3604 > ricohn -
Inutile d'être de mauvaise foi, je vous aurais remercié...
Merci pour le lien !
Messages postés
4429
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1568
0
Merci
Bonjour,

les fonction de recherche ne permettent de retourner qu'une seule occurrence. Si vous souhaitez plusieurs occurrences, vous pouvez regarder de ce côté.

Cordialement.