Menu

Extraire mois à partir d'une date sur Excel [Résolu/Fermé]

-
Bonjour,

Je voudrais savoir quelle formule je dois utiliser pour réaliser la chose suivante :

J'ai des dates dans une colonne :
A
01/01/2001
03/05/2002
09/11/2003
etc..

et je voudrais faire apparaitre dans les colonnes suivantes :
B
Janvier
Mai
Novembre
...

C
2001
2002
2003
...

Merci d'avance pour vos conseils car j'ai 1300 lignes et je ne me vois pas tout taper à la main ;)
Afficher la suite 

5 réponses

Meilleure réponse
approuvée par Jean-François Pillou le 5 déc. 2018
Messages postés
98
Date d'inscription
vendredi 4 janvier 2008
Statut
Membre
Dernière intervention
9 janvier 2019
95
97
Merci
Si la date est en A1, alors:

=CHOISIR(MOIS(A1);"janvier";"février";"mars";"avril";"mai";"juin";"juillet";"aout";"septembre";"octobre";"novembre";"décembre")

Dire « Merci » 97

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41248 internautes nous ont dit merci ce mois-ci

il y a encore plus simple:

=TEXTE(A1;"mmmm")
Merci beaucoup pour cette formule facile à adapter !
Pour les années ou les mois, ou encore en chiffre :)
Merci beaucoup cette formule m a aidé a avancer dans mon travail. May God blessé you
MERCI ca marche
Merci c'est top! :-)
Messages postés
116
Date d'inscription
jeudi 10 juin 2010
Statut
Membre
Dernière intervention
21 août 2013
43
20
Merci
Le plus simple est de recopier la date et de demander à n'afficher que le mois (Format -> cellule, dans les formats personnalisés mettre "mmmm").
Parfait, merci !
Je cherche toujours trop compliqué :s
chrij
Messages postés
116
Date d'inscription
jeudi 10 juin 2010
Statut
Membre
Dernière intervention
21 août 2013
43 -
N'oublie pas de mettre ton post en résolu !
6
Merci
Bonjour
Utiliser la formule Texte et le format pour convertir la date de la cellule en mois.
La cellule A1 contient la date, la formule
= Texte (A1;"mmmm")

donnera le résultat escompté.
3
Merci
=ANNEE(A1) me donne 1905 pour le 01/01/2008...

Mais bon ce n'est pas grave mes données sont classées par ordre chronologique, je peux donc remplir cela à la main.
chrij
Messages postés
116
Date d'inscription
jeudi 10 juin 2010
Statut
Membre
Dernière intervention
21 août 2013
43 -
Bizarre ça marche bien chez moi (je viens d'aller vérifer). Je sais pas trop où chercher plus.
Cette fois c'est bon, c'est parce que j'avais laissé "aaa" en format de cellule. Tout est rentré dans l'ordre, merci beaucoup !
quand je fais =mois(1/12/1952) ca me retourne 1/12/1900
Je n'arrive pas a cerner le probleme.
Merci de votre aide.
faire TEXTE(A1;"jj") :

Vous donne le jour
mm vous donne le mois
aa vous donne l'année.
vous pouvez faire varier le nombre de j, m ou a en fonction de la manière dont vous souhaitez voir apparaitre votre info... n'oubliez pas les guillemets
salut tu dois en plus de ça changé le format de la cellule en "standar" pour avoir l'année correcte
2
Merci
Bonjour
Autrement avec conversion de données (tu copies la colonne où est la date dans une autre colonne, en gardant des colonnes vides à droite puis conversion de données en largeur fixe) ça ne marche pas trop mal non plus.
Et si tu veux le nom des mois au lieu des numéros, tu peux le faire avec une fonction si : si(A1=1;"Janvier";si(A1=2;"Février"...)