Excel: raccourci formule pourcentage? [Résolu/Fermé]

Messages postés
3
Date d'inscription
vendredi 15 avril 2011
Statut
Membre
Dernière intervention
15 avril 2011
- - Dernière réponse : Mike-31
Messages postés
16983
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 novembre 2019
- 16 avril 2011 à 18:52
Bonjour,

Au lieu de toujours taper la formule =(B1/A1)-1 puis ensuite mettre en forme %, existe-t-il une fonction qui donne automatiquement le résultat mis en forme ?
(pour économiser la saisie de formule et la mise en forme)

Je cherche en vain.
D'avance merci
EF
Afficher la suite 

6 réponses

Messages postés
16983
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 novembre 2019
3679
0
Merci
Salut,

La logique voudrait que tu formate la ou les cellules en % et que tu écrives la formule comme cela

=((B1/A1)-1)

Ou en intégrant le format dans la formule qui prend un format texte

=TEXTE(((B1/A1)-1);"0,00%")
A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
Messages postés
3
Date d'inscription
vendredi 15 avril 2011
Statut
Membre
Dernière intervention
15 avril 2011
0
Merci
Salut Mike,

Merci de tes précisions mais elles ne solutionnent pas mon pb.
Je cherche la fonction qui économise la saisie de la formule pour donner directement automatiquement le résultat.

Pour faire un parallèle, la fonction 'somme' avec son raccourci 'somme automatique' évite de rentrer +A1+B1+C1+...

De la même manière, existe-t-il une fonction qui donne le résultat en % de =(B1/A1)-1 ?

Help, merci.
EF
Messages postés
23082
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 novembre 2019
5760
0
Merci
Bonsoir,

En définissant ta formule dans un nom tu gagneras un peu de temps.
Ca ne marchera que si tes cellules sont toujours au même endroit en relatif.
Avec tes valeurs en A1 et B1, sélectionner C1 puis :
menu 'insertion / nom / définir...'
'noms dans le classeur:' pc (ou autre nom court)
'fait référence à:' =TEXTE((Feuil1!B1/Feuil1!A1)-1;"0.0%")
Si Excel te met les références en absolu, retourne éditer la formule pour supprimer les $

Ensuite si tu as tes 2 valeurs en B2 et C2 par exemple, en D2 saisi:
=pc

eric

edit : ou si tu as à chaque fois des grandes plages à traiter ça peut être fait par macro.
Messages postés
3
Date d'inscription
vendredi 15 avril 2011
Statut
Membre
Dernière intervention
15 avril 2011
0
Merci
Merci Eric,
Tu réponds à ma question.
Seul bémol comme tu le précises, ça ne marche que si les cellules sont toujours positionnées de la même manière, dans ce cas sur même ligne à la suite.
Pour obtenir le résultat de 2 cellules par exemple l'une en dessous de l'autre, nécessité de recréer une formule. Easy, logique.
Mais n'y a-t-il vraiment pas de fonction prédéfinie dans Excel qui donne ce résultat?
En tout cas, merci.

Eric F
Raymond PENTIER
Messages postés
50375
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 novembre 2019
11228 -
"Mais n'y a-t-il vraiment pas de fonction prédéfinie dans Excel qui donne ce résultat?"

NON, vraiment de chez vraiment !
eriiic
Messages postés
23082
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
20 novembre 2019
5760 -
Re,

Combien même elle existerait (on peut la faire en fonction personnalisée) ça ne te ferait gagner que le -1.
Excel ne peut pas deviner quelles cellules utiliser...
eric
0
Merci
Merci à vous, sympas.
Bon we
EF
Messages postés
16983
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 novembre 2019
3679
0
Merci
Re,

Je reviens sur la discussion pour confirmer ce qui t'a été dit, Excel ne peut deviner tes intensions, à part que nous ayons mal compris.
Tu peux formater une plage de cellule en % exemple mets en surbrillance la plage D1 à D20 et clic droit sur cette plage/Format de cellule/onglet Nombre/sélectionne Pourcentage
Toute les saisies ou résultat de formule dans cette plage seront automatiquement en %
exemple ta formule =(B1/A1)-1 donnera 300,00%

A+
Mike-31

Une période d'échec est un moment rêvé pour semer les graines du savoir.
gbinforme
Messages postés
15079
Date d'inscription
lundi 18 octobre 2004
Statut
Contributeur
Dernière intervention
23 juin 2018
3732 -
Bonjour Mike-31,

Désolé de ne pas aller dans ton sens, mais avec les formules que tu proposes, pour obtenir les résultats que tu annonces il faut par exemple mettre 100 en A1 et 400 en B1 :

il me semblerai que 300% soit beaucoup plus juste que 3,00% ?
Mike-31
Messages postés
16983
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
18 novembre 2019
3679 -
Salut Gbinforme

Exact je modifie

Cordialement