Problème de suppression de macro excel [Résolu/Fermé]

- - Dernière réponse :  Midou - 28 mars 2014 à 20:33
Bonjour, quand j'ouvre un fichier excel, il m'affiche la fenêtre d'activation ou désactivation des macros. Je ne veux plus qu'il m'affiche cette fenêtre, donc je fait : "activer macro" ou "desactiver macro" c'est pareil, puis outils, macros, il m'affiche la fenêtre "macro", mais il n'y a rien à l'intérieur ce qui fait que je ne peux supprimer aucune macro. Je referme tout, et quand je ré-ouvre mon fichier c'est pareil il me ré-affiche la fenêtre "activer macro" ou "desactiver macro" !!! Quelqu'un peut-il m'aider ?
merci
Afficher la suite 

16 réponses

Meilleure réponse
35
Merci
J'ai trouvé la solution !

Enfin pour moi :)

Il arrive que la suppression d'une macro via Outils/macro/macro efface la macro mais pas le module Visual Basic. C'est le module, même vide, qui déclenche le message...Donc allez dans Outils/macro/Visual Basic editor et regarder dans la liste des fichiers VBA : trouver le fichier module et le supprimer (souris bouton de droite), fermer et sauvegarder le fichier et voilà !

Bonne chance !!!!

Dire « Merci » 35

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 64130 internautes nous ont dit merci ce mois-ci

Trop bien merci!
Merci beaucoup !
Histoire de contribuer... J'avais un document Word avec un problème similaire, mais dans VB nada, ni module ni rien dans ThisDocument. J'ai fini par créer un module, l'ai supprimé, problème réglé.
super merci cela fonctionne !!!!
j'ai pas trouvé ce chemin : Outils/macro/Visual Basic editor
7
Merci
Voici ce que j'ai trouvé...... Aide de Microsoft ......http://support.microsoft.com/kb/329950/fr
1. Ouvrez le fichier Excel, puis cliquez sur Désactiver les macros lorsque le message d'erreur s'affiche.
2. Appuyez sur les touches ALT+F11 pour démarrer Visual Basic Editor.
3. Dans la fenêtre Explorateur de projets, recherchez le nom de fichier. Par exemple, recherchez « VBAProject nom_fichier.xls » (sans les chevrons).
4. Développez la liste Objets.
5. Développez la liste Modules.
6. Sélectionnez tous les modules qui apparaissent dans la liste Modules, puis appuyez sur SUPPR pour supprimer le module. (Le module sera probablement nommé "Module1", "Module2", "Module4" ou un nom de ce type).
7. Fermez Visual Basic Editor, puis enregistrez le fichier Excel.
Super, ça marche bien pour moi !!!
6
Merci
Bonjour à tous,
Merci pour vos contributions. Les solutions proposées ci-dessus n'etaient pas exactement adaptée a mon cas, mais elles m'ont mis sur la piste. En effet dans mon cas les procedures ne se trouvaient pas dans un module et en plus il s'agissait d'une macro qui s'executait sur pression de la touche ALT... Apres avoir effacé le code, la touche ALT etait toujours desactivée, non seulement dans le Classeur concerné mais aussi dans tous les aurtes que j'ouvrais !!! Pour vous dire a quel point c'etait embettant... d'autant plus que la macro semblait "fantome". Voici ce que j'ai fais pour resoudre mon probleme:
1. S'assurer que le niveau de Securite des macros est a MOYEN
2. Ouvrez le fichier Excel, puis cliquez sur "Désactiver les macros" lorsque vous y etes invité.
3. Appuyez sur les touches ALT+F11 pour démarrer Visual Basic Editor.
4. Dans la fenêtre Explorateur de projets recherchez le nom de fichier. Par exemple, recherchez « VBAProject nom_fichier.xls » (sans les chevrons)
5. Développez la liste Objets.
6. selectionnez l'objet auquel vous aviez assosié votre code (Sheet1, Sheet2, Sheet3... ou ThisWorkbook) .
7. Placez le pointeur dans la fenetre de code et faites "CTRL+A" ou "Menu/Edition/Selectionner Tout".
8. Allez a Menu/Edition/Effacer (Suppr)
7. Fermez Visual Basic Editor, puis enregistrez le fichier Excel.

@+
Bonjour,

J'ai trouvé votre réponse pensant qu'elle pourrait résoudre mon problème mais ce n'est pas le cas. Peut-être fais-je une mauvaise manip. Je veux supprimer une macro qui ouvre un feuille excel chaque fois que j'ouvre un classeur. J'ai utilisé la méthode qui consiste à supprimer les modules mais elle est sans effet. J'ai pensé que la votre pourrait fonctionner mais peut-être fais-je une mauvaise manip.Lorsque je suis dans la liste d'objet de l'exporateur VBA, je positionne le curseur dans la fenêtre mais il n'y a aucun code. Est-ce normal ?

Merci de votre aide.
3
Merci
J'avais le même problème...
Pour m'en sortir, j'ai :
- sauvegardé le fichier au format XML (Fichier / Enregistrer sous..., sélectionner "Feuille de calcul XML (*.xml)") => une fenêtre d'avertissement prévient que notamment les projets VB ne sont pas sauvegardés,
- réouvert le doc XML avec Excel,
- re-sauvegardé en classeur xls (Fichier / Enregistrer sous..., sélectionner "Claseur Microsoft Excel (*.xls)").
Pour moi, cela semble avoir marché...
Super solution, ça a marché pour moi! J'en avais marre de voir cette fichu fenêtre me demandant si je voulais activer les macros! Merci +++
Super solution, c'est la plus simple, pour mon avis car je n'ai aucune notion du logiciel Visual Basic, merci
Messages postés
1857
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
20 septembre 2019
1265
2
Merci
On peut quand même penser que si, avec le niveau moyen, Excel te demande d'activer ou non les macros, c'est qu'il y a des macros dans ton classeur.
Si tu ne les vois pas, c'est sans doute (hypothèse) que tu les cherches en faisant :
- Outils/Macro/Macros...

Ce moyen d'accéder aux macros ne montre que celles qui peuvent être lancées avec le bouton Exécuter.
En revanche, les macros des formulaires n'apparaissent pas. Et celles qui demandent des paramètres au lancement non plus.

Est-ce que tu es allé dans l'Editeur Visual Basic ?
Utilisateur anonyme -
Bonjour, oui je suis allé dans visual basic je ne trouve pas de macro non plus, je me souviens d'avoir écrit une macro il y a un certain temps !!! je me demande si ce n'est pas ça le problème, mais je devrais quand même arriver à la retrouver et à la supprimer. Merci pour ton aide, mais comme ça ce n'est pas évident, si je trouve je te passe un message
Armojax
Messages postés
1857
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
20 septembre 2019
1265 > Utilisateur anonyme -
Hello,

Tu peux avoir des macros :
- soit dans des modules
- soit dans des UserFrom
- soit associées à des feuilles de calcul ou à ThisWorkbook...
As-tu bien regardé partout ?
Utilisateur anonyme > Armojax
Messages postés
1857
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
20 septembre 2019
-
Salut, je t'avoue que je ne sais pas dire si j'ai vraiment bien regardé partout, j'ai enregistré mon fichier sous un autre nom, je l'ai vidé de son contenu, j'ai supprimé le mot de passe, à l'ouverture du nouveau fichier j'ai toujours la fenêtre concernant les macros. J'aurai pu te faire passer ce fichier mais sur le site CCM je ne vois pas de possibilité de joindre un document. En tout cas je te remercie encore de ton aide, je vais continuer de chercher
Messages postés
5155
Date d'inscription
mercredi 20 juillet 2005
Statut
Contributeur
Dernière intervention
6 mars 2019
2619
1
Merci
Bonjour,

S'il rien n'apparaît dans la liste, c'est peut-être que tu n'affiches pas toutes les macros mais seulement celles liées au modèle actif ? Regarde dans la liste déroulante.

+ Ton anti-virus est-il à jour, est actif ?
Utilisateur anonyme -
Bonjour, mon antivirus est à jour et est actif, dans la liste déroulante j'ai la possibilité de sélectionner 3 choses différentes:
1) nomdemonfichier.xls
2) ce classeur
3) tous les classeurs ouverts

Quelque soit le choix que je fasse, je n'ai aucune macro dans ma liste et de ce fait je n'ai que le bouton "annuler" qui est actif.

Merci pour ta réponse
Messages postés
1857
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
20 septembre 2019
1265
1
Merci
Salut,

C'est le niveau de sécurité dans Excel qu'il faut adapter :
- Outils / Options / Onglet Sécurité / Bouton Sécurité des macros
Tu as actuellement le niveau Moyen. Seul le niveau Bas t'évitera d'avoir un message à l'ouverture de tes classeurs. A toi de prendre les sécurités nécessaires...
Utilisateur anonyme -
Bonjour et merci pour ton info, effectivement quand je passe le niveau de sécurité des macros au plus bas, je n'ai plus le message à l'ouverture du fichier. Mais ce que je ne m'explique pas c'est que si je remets le niveau de sécurité moyen le message réapparait alors que je ne vois aucune macro dans ce classer !!
Merci pour ton aide
0
Merci
J'ai le même soucis mais je ne peux pas enregistrer mon document en format .XML vu que excel ne me le propose pas dans son menu déroulant (c'est peut être dû à la version : j'ai microsoft office 2000).

J'ai aussi essayé un logiciel gratuit pour convertir ce fichier mais ça n'a pas réussi...si quelqu'un d'autre à une idée, elle sera la bienvenue!!

En attendant, j'ai mis le niveau de sécurité sur bas à défaut d'une vrai solution

Merci d'avance!
Messages postés
1857
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
20 septembre 2019
1265
-1
Merci
S'il n'y a rien de confidentiel, tu peux mettre ton classeur sur :
http://cjoint.com/

ou sinon me l'envoyer en pièce jointe à mon pseudo en minuscules chez free.fr.
-1
Merci
En quoi ce problème est-il résolu ? (Parce que j'ai le même problème à la maison : un macro attachée à un classeur alors qu'il n'y a plus le moindre code ni rien, je les avais effacé en pensant que ça supprimerait la macro ben non.)
-1
Merci
J'ai le même problème. Plus de macro mais toujours le foutu message. Puisque le fichier doit être envoyé à d'autres, c'est un vrai problème !!!

Et je ne vois pas en quoi il est résolu !!!!

François
-1
Merci
Bonjour,
Nous avons aussi ce problème au niveau professionnel : après suppression d'un bouton lançant une macro, et alors qu'il n'y a plus rien, Excel demande si on veut activer ou non les macros. Bien sûr en baissant le niveau de protection, le message disparait mais ce n'est pas la solution. Par contre la méthode proposée ne fonctionne pas. A moins qu'on ne s'y prenne mal. Merci de votre aide
-1
Merci
Bonjour,
J'ai exactement le même problème que décrit ci-dessus. Mon problème à moi est que j'utilise excel 2007 :)
Est-ce que quelqu'un sait comment on arrive à supprimer ces fameuses macros sur 2007?
Merci d'avance
-1
Merci
Merci beaucoup Cbu, j'ai eu du mal à trouver une solution, mais celle-ci me semble être la bonne !!!
-1
Merci
pareil même pb depuis des lustres sur un fichier et miracle. Qu'est ce que c'est bien des fois internet...
Messages postés
230
Date d'inscription
jeudi 19 novembre 2009
Statut
Membre
Dernière intervention
19 mai 2015
19
-1
Merci
Et pour supprimer un module en langage VBA, ça donne quoi?!

Merci =)
zivodul8
Messages postés
230
Date d'inscription
jeudi 19 novembre 2009
Statut
Membre
Dernière intervention
19 mai 2015
19 -
Oups, j'ai rien dit!

ActiveWorkbook.VBProject.VBComponents.Remove ActiveWorkbook.VBProject.VBComponents.Item("Module1")
Bonjour à tous,

Mes fichiers .xls comportant des macros supprimées et pas visibles en VBA continuaient à demander d'activer ou non les macros lors de l'ouverture.
Ces fichier pèsent + de 5 Mo et comportent une colossale quantité de formules, de mise en formes conditionnelles et de TCD
Ma solution :
Ouvrir le fichier (disons A.xls)
L'enregistrer sous A1.xls
Insérer une nouvelle feuille de calcul (ce sera utile par la suite)
Ouvrir un nouveau classeur vierge (disons 1.slx)
Faire afficher les deux fichiers en mosaïque (horizontale c'est plus pratique)
Faire glisser un à un les onglets de A.xls dans 1.xls jusqu'à ce qu'il ne reste plus que la feuille de calcul que vous venez d'insérer au début.
Fermer A1xls sans sauvegarder
Remettre les options que vous aviez dans déjà dans A ou A1.xls (i.e. : calcul au format afficher, etc...)
Enregistrer 1.xls sous A.xls (A1.xls servira de back-up si besoin)
Fermer.

Yapuka ré-ouvrir ( il n'y aura aucune trace de macro)

;-)
Merci pour ta solution Lepoune02!

Pour ceux qui comme moi ont une version d'excel ne permettant pas de faire glisser directement les onglets d'un classeur à l'autre, il faut aller dans Edition - Déplacer ou copier une feuille -sous "Déplacer les feuilles sélectionnées dans le classeur", sélectionner dans le menu déroulant "nouveau classeur" - cocher "créer une copie". Un nouveau classeur se crée avec les feuilles à l'identique, que l'on pourra enregistrer et rouvrir sans le vilain message.