[PHP] Signe supérieur non pris en compte ? [Fermé]

Signaler
-
lejedidelingo
Messages postés
153
Date d'inscription
samedi 1 mai 2010
Statut
Membre
Dernière intervention
2 janvier 2017
-
Bonjour, j'ai une page php avec un script d'hébergement d'image, bref tout ce qu'il y a de plus normal...
Il est dans le dossier www de wamp, et wamp est "allumé".
Seulement, dans mon code php entre les signes <?php et ?>, le signe supérieur :
>
Fait bugger tout le code, je ne comprend pas pourquoi.
Jai fouillé partout sur Internet, je n'ai pas trouvé une seule réponse o.o

Exemple :
J'ai ceci :

$variable = 5;
if ($variable > 3)
{
echo $variable . 'est supérieur a 3.';
}


Voilà ce qu'affichera ma page :

3) { echo $variable . 'est supérieur a 3.'; } ?>


Tout ce qui se trouve après le signe ">" a été ignoré.
Ça commence a m'énerver :x

Quelqu'un a une solution ?



5 réponses

Messages postés
153
Date d'inscription
samedi 1 mai 2010
Statut
Membre
Dernière intervention
2 janvier 2017
5
C'est bizzard, la syntaxe est correcte pourtant

Tu as essayé en remplaçant le > par = ?,

juste pour guise de test.

Tu es sur que le fichier a une extention php ?
j'ai test chez moi, sa marche niquel

voila le code que j'ai testé :


<?php

$variable = 5;
if ($variable > 3)
{
echo $variable . 'est supérieur a 3.';
}

?>

donc aucun soucis concernant la syntaxe
Messages postés
8896
Date d'inscription
vendredi 19 septembre 2003
Statut
Modérateur
Dernière intervention
20 août 2016
1381
Wep, ne serait pas tout le code qui pose problème?
Quand tu regardes la source de ta page générée sur ton navigateur, tu vois tout le code php ou seulement la partie après le ">" ?
C'est bon j'ai trouvé la solution !
Au lieu d'ouvrir le fichier en localhost, je l'ouvrais comme si c'était un fichier normal (C:\wamp\www\...)
lejedidelingo
Messages postés
153
Date d'inscription
samedi 1 mai 2010
Statut
Membre
Dernière intervention
2 janvier 2017
5
Oui il faut l'ouvrir sur le serveur.