Menu

Valeur d'une cellule dans une formule excel [Fermé]

-
Bonjour,

J'essaye de faire quelque chose de spécial et je ne sais pas comment l'expliquer en titre.
Bref, mettons que j'ai une cellule B2 avec la valeur 33 dedans.
J'aimerais prendre en compte une plage de cellule en fonction de cette valeur, c'est à dire que la plage basique ferais A3:A31.
J'aimerais faire en plus simple une plage qui donnerai A3:A(B2-1)
B2 retournerai 33 et donc B2-1 = 32 la plage ferais A3:A32.
Bref je suppose que ce n'est pas faisable de cette manière mais comment faire sans passer par des nommages etc etc...

Merci


Afficher la suite 

6 réponses

Meilleure réponse
2
Merci
Merci beaucoup ça fonctionne.

J'ai aussi des fonctions avec SOMMEPROD.

J'ai fais idem en écrivant cette fonction mais sans succès :

=SOMMEPROD((INDIRECT("'Résultats Enquête'!D3:D"&$O$3+2);"<35")*(INDIRECT("'Résultats Enquête'!F3:F"&$O$3+2);"Fumeur"))

Dire « Merci » 2

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 53006 internautes nous ont dit merci ce mois-ci

Vaucluse
Messages postés
24168
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 juillet 2019
4666 -
Re
la fonction SOMMEPROD ne nécessite pas de point virgule comme NB.SI, mais seulement les signes < > =

Ecrivez
=SOMMEPROD((INDIRECT("'Résultats Enquête'!D3:D"&$O$3+2)<35)*(INDIRECT("'Résultats Enquête'!F3:F"&$O$3+2)="Fumeur"))

et ne fumez pas trop, c'est mauvais pour la santé(surtout si c'est le plot) :-)

crdlmnt
Messages postés
602
Date d'inscription
dimanche 8 novembre 2009
Statut
Membre
Dernière intervention
21 juin 2015
195
0
Merci
Bonjour,

Je n'ai pas le temps de faire une réponse fournie, vous avez besoin de la formule =INDIRECT(....)
0
Merci
Je récupère bien la plage voulu par exemple :

=("D3:D"&I38+2)

Me renvoi une plage juste seulement dans une formule comme :

=(NB.SI('Résultats Enquête'!("D3:D"&I38+2);"<35"))

Plus rien ne fonctionne...

Que faire ?
Messages postés
24168
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 juillet 2019
4666
0
Merci
Bonjour
allez, on va prendre la relève:
=NB.SI(INDIRECT("'Résultats Enquête'!D3:D"&I38+2);"<35")
Attention à l'orthographe des libellés qui doivent être identiques entre la formule et les références et au fait que entre le premier guillemets et le nom de la feuille dans la formule, il y a une apostrophe.
crdlmnt

0
Merci
Merci beaucoup ça fonctionne !!!
0
Merci
Derniere question.
Pour une moyenne, pourquoi la formule suivante ne fonctionne pas ??
Elle pointe bien sur une plage valide de chiffres uniquement.
Elle affiche "#Valeur"

=MOYENNE("'Résultats Enquête'!D3:D"&$F$7)

Alors que lorsque je fais :

=MOYENNE('Résultats Enquête'!D3:D35)

Ca marche :)
Vaucluse
Messages postés
24168
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
8 juillet 2019
4666 -
Bonjour loko..
simplement parceque vous avez omis de placer le code INDIRECT qui transforme le texte que vous placez avec "'Résultats Enquête'!D3:D"&$F$7 en adresse effective pour excel.
la formule est:
=MOYENNE(INDIRECT("'Résultats Enquête'!D3:D"&$F$7))
crdlmnt
Quel idiot je suis !! Merci encore