EXCEL FORMULE CALCUL AVEC CONDITION [Résolu/Fermé]

Messages postés
96
Date d'inscription
jeudi 7 août 2008
Statut
Membre
Dernière intervention
29 décembre 2018
- - Dernière réponse : nougi
Messages postés
96
Date d'inscription
jeudi 7 août 2008
Statut
Membre
Dernière intervention
29 décembre 2018
- 7 janv. 2011 à 12:05
Bonjour,

Je souhaiterais faire une formule de calcul qui me permet de calculer le CA par date.

En gros, j'ai une colonne avec des dates, une autre avec des sommes et je voudrais pouvoir calculer le CA par mois.

Je recherche une formule du style : "si dans la colonne A la date est comprise entre 01/01/2011 et 31/01/2011 alors je veux la somme des montants correspondants (à ces dates) en colonne B"

Je vous remercie par avance pour votre aide.
Afficher la suite 

3 réponses

Messages postés
1270
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
495
0
Merci
Bonjour,

Pour les dates de A1 à A100 et les montants de B1 à B100 :
Pour le mois de janvier (1):
=SOMMEPROD((MOIS(A1:A100)=1)*(B1:B100))

Ou pour le mois saisi en D1 sous la forme 1, 2, etc...
=SOMMEPROD((MOIS(A1:A100)=D1)*(B1:B100))

Bonne journée.
Messages postés
96
Date d'inscription
jeudi 7 août 2008
Statut
Membre
Dernière intervention
29 décembre 2018
1
0
Merci
Merci

Cela marche pour le calcul de mon mois de janvier, mais pas pour les autres mois

Ma colonne A contient des dates tout mois confondus, et je dois extraire un CA mensuel.

Normalement j'aurais mis un sous total mais là j'ai un filtre, donc je suis oblige de mettre mon total mensuel à la fin de mon tableau.

Le 1 de la formule correspond-il au 1 du mois de janvier ? Dans ce cas, pourquoi quand je met 2 pour février excel me dit que c'est faux ?
Messages postés
96
Date d'inscription
jeudi 7 août 2008
Statut
Membre
Dernière intervention
29 décembre 2018
1
0
Merci
Autant pour moi, c'est ma liste déroulante qui me posait problème...

Je vous remercie beaucoup pour votre aide !!

Bonne journée.