[Excel] Transfert automatique de données [Résolu/Fermé]

- - Dernière réponse :  Francis - 13 déc. 2010 à 22:04
Bonjour,

Voici un schéma simplifié de mon problème.
En vrai, je veux faire ça sur environ 1000 lignes.

Fichier 1:
Colonne A / Colonne B
----
info 1 / data 1
info 2 / data 2
info 3 / data 3
info 4 / data 4
info 5 / data 5

Fichier 2:
Colonne A / Colonne B
----
info 1 /
info 5 /
info 4 /
info 2 /
info 3 /

J'aimerai que la colonne B du fichier 2 se remplissent automatiquement et mettent la bonne data du fichier 1 en fonction de la bonne info de la colonne A. J'espère que je suis assez clair.

En gros, après opération, je veux avoir ça :

Fichier 2:
Colonne A / Colonne B
----
info 1 / data 1
info 5 / data 5
info 4 / data 4
info 2 / data 2
info 3 / data 3

Est-ce qu'il existe une formule pour ce genre d'opération?
Faut-il utiliser les macro?

Merci à vous,

Francis



Afficher la suite 

1 réponse

Messages postés
919
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
264
0
Merci
Bonjour,
Tu peux utiliser une formule du type :
=RECHERCHEV(A1;[Fichier1.xls]Feuil1!$A$1:$B$5;2)


Si tu as besoin de détails, n'hésite pas.
@+
Vaucluse
Messages postés
24615
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
21 octobre 2019
4842 -
Bonsoir tous:
un petit complément à la proposition de Gord.
Si la colonne de recherche n'est pas classée avec le code utilisé, la formule renvoi une valeur erronée.
Pour éviter cet inconvénient, il faut compléter la formule avec un code excel qui interdit l'affichage de valeur proche
soit 0, FAUX ou même simplement le;
la formule devient:
=RECHERCHEV(A1;[Fichier1.xls]Feuil1!$A$1:$B$5;2;0) ou 2;FAUX) ou 2;)
Crfdlmnt
Merci beaucoup.
C'est exactement ce que je cherchais.