Css et IE incompatible --> onglets [Résolu/Fermé]

Messages postés
45
Date d'inscription
mardi 13 décembre 2005
Statut
Membre
Dernière intervention
13 juillet 2006
- - Dernière réponse : deb_fab
Messages postés
45
Date d'inscription
mardi 13 décembre 2005
Statut
Membre
Dernière intervention
13 juillet 2006
- 28 déc. 2005 à 14:08
bonjour je dois faire un site avec un menu en onglet.
mais il y a des problème avec IE (et oui encore)

le menu se présente en escalier alors qu'avec firefox c'est ok
voila le code :

.PHP :

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN""http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">
<head>
<title>Bienvenue sur le site AMPO</title>
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1" />
<link rel="stylesheet" media="screen" type="text/css" title="AMPO_1" href="AMPO_1.css" />
</head>
<body>

<ul class="onglets">
<li><a class="li_onglet" href="./?page=essai1">________1</a></li>
<li><a class="li_onglet" href="/essai2/">________2</a></li>
<li><a class="li_onglet" href="/essai3/">________3</a></li>
<li><a class="li_onglet" href="/essai4/">________4</a></li>
<li><a class="li_onglet" href="/essai5/">_______5</a></li>
<li><a class="li_onglet" href="/essai6/">________6</a></li>
</ul>

<div class="commun">
<ul class="menu">
<li><a class="li_menu" href="./?page=essai11">essai11</a></li>
<li><a class="li_menu" href="/essai12/">essai12</a></li>
<li><a class="li_menu" href="/essai13/">essai13</a></li>
<li><a class="li_menu" href="/essai14/">essai14</a></li>
<li><a class="li_menu" href="/essai15/">essai15</a></li>
<li><a class="li_menu" href="/essai16/">essai16</a></li>
</ul>
</div>
</body>
</html>


.CSS :

.onglets
{
list-style-type : none;
padding-bottom: 34px;
padding-left: 260px;
margin: 0;
}

.li_onglet
{
float: left;
font-family: "comic sans ms","Arial", "Verdana";
margin: 2px 2px 0 20px;
border: 1px solid black;
background-color : #ff5757;
}

a
{
display: block;
color: white;
padding: 4px;
text-decoration :none;
}

a:hover
{
color: #63b13d;
background: white;

}

.commun
{
float : left;
font-family: "comic sans ms","Arial", "Verdana";
width : 17%;
border-width: 2px;
}

.menu
{
padding-top: 34px;
list-style-type : none;
margin: 0;
}

.li_menu
{
margin-top:4px;
color: white;
background: #ff5757;
text-align:center;
border: 1px solid black;
}

body
{
background-image:url("fondint2.jpg");
background-repeat:repeat-x;
}


quelqu'un a une solution svp ?
Afficher la suite 

2 réponses

Meilleure réponse
approuvée par Jean-François Pillou
Messages postés
2027
Date d'inscription
jeudi 22 septembre 2005
Statut
Membre
Dernière intervention
18 novembre 2015
200
1
Merci
quelqu'un a une solution svp ?
Ouais m'sieur, gère ca avec un tablea (<table>) tu fais ta mise en page avec, je te conseille vivement de fixer les tailles en pixel et non en % et test bien avec IE et Firefox et autres car des fois selon le browser, ca peut changer, si t'es en Php tu peux tester ca avec la variable HTTP_REMOTE_JeSaisPlus hihihi oui tu peux tester le navigateur avec php et les variables d'environnement...

Voilà

Zep3k!GnO

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 58382 internautes nous ont dit merci ce mois-ci

Messages postés
45
Date d'inscription
mardi 13 décembre 2005
Statut
Membre
Dernière intervention
13 juillet 2006
8
0
Merci
eureka ! sa marche mieu comme sa
merci Zep3k!GnO