Ghost boot PXE [Fermé]

Signaler
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
-
dharth
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
-
Bonjour,

Je dois faire un serveur Ghost sous win server 2008 datacenter, et fair booter les machinnes clientes en PXE.

Le Service DHCP est activé sur mon 2008, et fonctionnel sur un poste en XP (quand windows est démarré, la machinne reçoit une addresse). Mais quand je démarre sur le LAN (en PXE), il se met en recherche d'addresse et finit par afficher : "Reboot and select proper device or insert boot media in selected boot device and press a key"

Je veux absolument arriver à booter en pxe et il n'est donc pas question de boot sur cd-rom ou clé usb.

Ma version de ghost est la 11.5.0.2113 .



14 réponses

Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
As tu activé le service d'installation à distance? Sinon à tu bien créer l'image disque bootable avec ghost?
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
petit rappel pour une installation pxe :
- DHCP qui renvoie automatiquement le nom du serveur pxe
- Serveur pxe qui tourne sur windows server et qui est configuré correctement (ton Windows serv et ton client se servent du DHCP d'une box ou bien du dhcp du serveur?)
- un serveur tftp
- Une image ghost

Peut tu donner ta config de ghost et de ton tftp?
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
C'est la première fois que je fais un PXE...,
Le serveur DHCP est bien activé mais par contre je ne sais pas comment faire le PXE et le TFTP,
Le tftp je crois connaitre un logiciel mais n'existe t'il pas une solution pour le faire directement sous 2008?
Et le pxe, je pensais que ghost l'installait automatiquement, puisque il créé un dossier Boot quqnd j'exécute le ghost boot wizard.
Donc comment faire le pxe et le tftp sur le 2008 ?
Je fais ça pour un test dans mon entreprise, je suis habituellement juste technicien informatique, j'avais déja manipulé ghost, mais le pxe etait déja installé sur le serveur.
Merci.
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
pour le tftp sous windows server 2008 c'est assez complexe:
Installer le rôle "Transport" du service de déploiement WDS, et seulement ce rôle. : ServerManagerCmd -install WDS-Transport
on peut aussi installer la fonctionnalité "Client TFTP" pour des tests : ServerManagerCmd -install TFTP-Client
Il est intéressant que le service soit démarré automatiquement : sc config wdsserver start= auto
Paramétrons la racine du serveur TFTP : reg add HKLM\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WDSTFTP /v RootFolder /t REG_SZ /d x:\tftp
Modifions le filtre pour servir directement depuis la racine : reg add HKLM\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WDSTFTP /v ReadFilter /t REG_MULTI_SZ /d \* /f
Démarrons le service : sc start wdsserver

Si tu n'a jamais touché au pxe ca risque d'etre difficile. Essaye déja de démarrer le service tftp.
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Merci, je vais déja essayer de faire ça.
:)
dharth
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
ok bon courage, car windows server 2008 c'est quand même pas top ^^
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Me voila de retour, mais avec un problème sur le tftp, quand je rentre la ligne

reg add HKLM\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WDSTFTP /v RootFolder /t REG_SZ /d x:\tftp

Il me dit Erreur: Paramètre incorrect.

Peut être est-ce les options qu'il faut que je modifie mais je ne sais pas quoi mettre à la place.

Merci
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
essaye d'aller voir sur ce lien : https://docs.microsoft.com/en-us/previous-versions/windows/it-pro/windows-server-2008-R2-and-2008/dd348475(v=ws.10)?redirectedfrom=MSDN

tu descent sur la page jusqu'à "Pour configurer le serveur"
kab51
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Merci, j'essaye sa et je tiens au courrant.
Messages postés
11459
Date d'inscription
mardi 19 janvier 2010
Statut
Contributeur
Dernière intervention
2 avril 2020
965
C'est peut-être débile comme proposition, mais la seul fois ou j'ai toucher au PXE, je devais au préalable aller dans le bios de chaque machine client pour autoriser le PXE...
kab51
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Bonjour,
Le problème n'est pas que le PXE ne marche pas, c'est qu'il n'est pas installé, mais la de toute façon j'en suis encore au tftp... ;)
Merci
lepseudokejemetparcekejesaipakoi
Messages postés
11459
Date d'inscription
mardi 19 janvier 2010
Statut
Contributeur
Dernière intervention
2 avril 2020
965
Oki désolé j'avais pas tout bien compris...^^
Et bon courage en tout cas !
kab51
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Merci ^^ !
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Me revoila,
Toujours avec le problème de TFTP, j'ai suivi PAS A PAS la procédure décrite dans le lien, tout SEMBLE bien je passer, le tftp redémmare, aucune erreur apparente.
Sauf que, en allant dans l'interface "services de déploiement Windows pour vérifier le tftp, je rencontre l'erreur suivante:
Une erreur s'est produite lors de la tentative d'initialisation du fournisseur WDSPXE à partir de C:\Windows\system32\wdspxe.dll. Le serveur des services de déploiement windows sera arrétè.
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
c'est possible que ce soit la dll qui déconne. Dans tout les cas je pense que l'erreur ne vient pas d'une fausse manip dans la conf, mais d'un problème de fichier de windows server. J'ai regardé sur plusieurs site et je n'ai pas trouvé de lien permettant de la télécharger. Je conseille donc d'installer une autre version de windows server 2008 sur un autre pc et de copier la dll sur le serveur actuel.
kab51
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Bonjour,
Solution radicale, mais je vais essayer.
Merci
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
Bon j'ai regardé pour cet erreur, elle vient du fait que le DHCP est installer sur la même machine que le service de déploiement.

méthode 1:
dans l'invite de commande : /UseDhcpPorts:No set-Server WDSUTIL

OU

méthode 2:
- démarrer -> exécuter -> wdsmgmt.msc -> appuyer sur entrer
- Dans la fenêtre Services de déploiement Windows , développer serveurs , cliquer avec le bouton droit sur le nom du serveur WDS et puis cliquer sur Propriétés .
- Dans la boîte de dialogue Propriétés du serveur , cliquer sur l'onglet DHCP
- Désactiver la case à cocher ne pas écouter sur le port 67 , puis cliquez sur Appliquer.


Essaye ca et tient moi au courant.
kab51
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Quand j'essaye de faire executer=>
wdsmgmt.msc
, il ne trouve pas.
J'ai donc lancé une recherche du fichier dans les dossirers système, la pas de souci, il le trouve, mais quand je le lance, la fenêtre s'affiche avec l'erreur
MMC n'a pas pu créer le composant logiciel enfichable.
.
Je comprend plus...
<ironie>Vive Windows !!!</ironie>
dharth
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
et quand tu passe par l'invite de commande?
kab51
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Syntaxe du nom de fichier, de répertoireou de volume incorrecte
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
cherche dans le registre ici : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WDSServer\Providers\WDSPXE

et passe la valeur de UseDHCPPorts à 1
kab51
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Même aprés modification, même problème...
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Bonjour,
Petit UP pour dire que je n'ai toujours pas résolu mon problème. Si quelqun peut m'aider.
Merci
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
J'ai bien cherché sur le net, je n'ai rien pu trouver d'autre. De plus je ne connais pas très bien windows server donc je ne pourrais pas plus t'aider. Au niveau du message d'erreur "MMC n'a pas pu créer..." ca pourrait venir des droits mais je suppose que tu est admin donc je ne voit pas de quoi ca pourrait venir.
désolé et bon courage.
kab51
Messages postés
388
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
20 janvier 2019
74
Merci quand même, ton aide m'a fortement avancé, au moins je sais qu'il faut le tftp maintenant ^^.
dharth
Messages postés
140
Date d'inscription
dimanche 6 avril 2008
Statut
Membre
Dernière intervention
23 août 2012
13
pas de soucis :)