WiFi en mode Ad-Hoc entre 2 PC sous XP SP2 [Fermé]

Signaler
Messages postés
4
Date d'inscription
mardi 13 décembre 2005
Statut
Membre
Dernière intervention
16 décembre 2005
-
kaumune
Messages postés
18638
Date d'inscription
lundi 26 novembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2020
-
Bonjour ,
J'ai 2 PCs qui fonctionnent sous XP SP2. Ils ont les cartes WiFi installées. Je n'arrive pas à les faire dialoguer en mode Ad-Hoc (car je n'ai pas de Point d'accès). l'un des deux est relié à une FreeBox. Mon but est évidemment de partager les documents, imprimantes et Internet.
Quelqu'un peut-il m'aider dans la configuration des PCs. je n'ai pas trouvé le mode Ad-Hoc , mais seulement le mode Infrastructure dans la configuration proposée par XP.
Merci!

7 réponses

Messages postés
29130
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 janvier 2020
6744
Celà peut venir de tes routes qui sont mauvaises. Sur les deux pcs fais : démarrer, exécuter, cmd

Dans la fenêtre noire tape les deux commandes
ipconfig /all
route print


Copie le résultat en cliquant sur le coin supérieur gauche de la fenêtre. Précise bien lequel est relié à la freebox et par quel type de carte.

@+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 81159 internautes nous ont dit merci ce mois-ci

Lavelle
Messages postés
4
Date d'inscription
mardi 13 décembre 2005
Statut
Membre
Dernière intervention
16 décembre 2005

Voici le résultat :
Sur ordinateur relié en direct sur la Freebox

>ipconfig/all

Configuration IP de Windows

Nom de l'hôte . . . . . . . . . . : MAMAN
Suffixe DNS principal . . . . . . :
Type de noud . . . . . . . . . . : Inconnu
Routage IP activé . . . . . . . . : Non
Proxy WINS activé . . . . . . . . : Non

Carte Ethernet Connexion réseau sans fil 5:

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : IEEE 802.11g Wireless Cardbus/PCI Ad
apter #4
Adresse physique . . . . . . . . .: 00-40-F4-BA-A4-CB
DHCP activé. . . . . . . . . . . : Oui
Configuration automatique activée . . . . : Oui
Adresse IP. . . . . . . . . . . . : 0.0.0.0
Masque de sous-réseau . . . . . . : 0.0.0.0
Adresse IP. . . . . . . . . . . . : fe80::240:f4ff:feba:a4cb%4
Passerelle par défaut . . . . . . :
Serveur DHCP. . . . . . . . . . . : 0.0.0.0
Serveurs DNS . . . . . . . . . . : fec0:0:0:ffff::1%1
fec0:0:0:ffff::2%1
fec0:0:0:ffff::3%1

Carte Ethernet Connexion au réseau local:

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Eth
ernet NIC
Adresse physique . . . . . . . . .: 00-20-ED-95-B9-FD
DHCP activé. . . . . . . . . . . : Oui
Configuration automatique activée . . . . : Oui
Adresse IP. . . . . . . . . . . . : 81.56.187.223
Masque de sous-réseau . . . . . . : 255.255.255.0
Adresse IP. . . . . . . . . . . . : fe80::220:edff:fe95:b9fd%5
Passerelle par défaut . . . . . . : 81.56.187.254
Serveur DHCP. . . . . . . . . . . : 81.56.187.254
Serveurs DNS . . . . . . . . . . : 212.27.53.252
212.27.54.252
fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2
Bail obtenu . . . . . . . . . . . : mercredi 14 décembre 2005 09:50:11
Bail expirant . . . . . . . . . . : mercredi 14 décembre 2005 10:00:11

Carte Tunnel Teredo Tunneling Pseudo-Interface :

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Adresse physique . . . . . . . . .: FF-FF-FF-FF-FF-FF-FF-FF
DHCP activé. . . . . . . . . . . : Non
Adresse IP. . . . . . . . . . . . : fe80::5445:5245:444f%6
Passerelle par défaut . . . . . . :
NetBIOS sur TCPIP. . . . . . . . : Désactivé

Carte Tunnel 6to4 Tunneling Pseudo-Interface :

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : 6to4 Tunneling Pseudo-Interface
Adresse physique . . . . . . . . .: 51-38-BB-DF
DHCP activé. . . . . . . . . . . : Non
Adresse IP. . . . . . . . . . . . : 2002:5138:bbdf::5138:bbdf
Passerelle par défaut . . . . . . : 2002:c058:6301::
2002:836b:213c:1:e0:8f08:f020:8
2002:c058:6301::c058:6301
2002:836b:213c::836b:213c
Serveurs DNS . . . . . . . . . . : fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2
NetBIOS sur TCPIP. . . . . . . . : Désactivé

Carte Tunnel Automatic Tunneling Pseudo-Interface :

Suffixe DNS propre à la connexion :
Description . . . . . . . . . . . : Automatic Tunneling Pseudo-Interface

Adresse physique . . . . . . . . .: 51-38-BB-DF
DHCP activé. . . . . . . . . . . : Non
Adresse IP. . . . . . . . . . . . : fe80::5efe:81.56.187.223%2
Passerelle par défaut . . . . . . :
Serveurs DNS . . . . . . . . . . : fec0:0:0:ffff::1%2
fec0:0:0:ffff::2%2
fec0:0:0:ffff::3%2
NetBIOS sur TCPIP. . . . . . . . : Désactivé

>route print
===========================================================================
Liste d'Interfaces
0x1 ........................... MS TCP Loopback interface
0x2 ...00 40 f4 ba a4 cb ...... IEEE 802.11g Wireless Cardbus/PCI Adapter #4 - M
iniport d'ordonnancement de paquets
0x3 ...00 20 ed 95 b9 fd ...... Realtek RTL8139/810x Family Fast Ethernet NIC -
Miniport d'ordonnancement de paquets
===========================================================================
===========================================================================
Itinéraires actifs :
Destination réseau Masque réseau Adr. passerelle Adr. interface Métrique
0.0.0.0 0.0.0.0 81.56.187.254 81.56.187.223 20
81.56.187.0 255.255.255.0 81.56.187.223 81.56.187.223 20
81.56.187.223 255.255.255.255 127.0.0.1 127.0.0.1 20
81.255.255.255 255.255.255.255 81.56.187.223 81.56.187.223 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
224.0.0.0 240.0.0.0 81.56.187.223 81.56.187.223 20
255.255.255.255 255.255.255.255 81.56.187.223 81.56.187.223 1
255.255.255.255 255.255.255.255 81.56.187.223 2 1
Passerelle par défaut : 81.56.187.254
===========================================================================
Itinéraires persistants :
Aucun

Sur ordinateur portable



>ipconfig/all

Configuration IP de Windows

Nom de l'hôte . . . . . . . . . . : PBELL
Suffixe DNS principal . . . . . . :
Type de noud . . . . . . . . . . : Mixte
Routage IP activé . . . . . . . . : Non
Proxy WINS activé . . . . . . . . : Non

Carte Ethernet Connexion au réseau local:

Statut du média . . . . . . . . . : Média déconnecté
Description . . . . . . . . . . . : Realtek RTL8139/810x Family Fast Eth
ernet NIC
Adresse physique . . . . . . . . .: 00-40-D0-7D-24-32

Carte Ethernet Connexion réseau sans fil:

Statut du média . . . . . . . . . : Média déconnecté
Description . . . . . . . . . . . : Intel(R) PRO/Wireless 2200BG Network
Connection
Adresse physique . . . . . . . . .: 00-15-00-12-00-3C

>route print
===========================================================================
Liste d'Interfaces
0x1 ........................... MS TCP Loopback interface
0x2 ...00 40 d0 7d 24 32 ...... Realtek RTL8139/810x Family Fast Ethernet NIC -
Miniport d'ordonnancement de paquets
0x3 ...00 15 00 12 00 3c ...... Intel(R) PRO/Wireless 2200BG Network Connection
- Miniport d'ordonnancement de paquets
===========================================================================
===========================================================================
Itinéraires actifs :
Destination réseau Masque réseau Adr. passerelle Adr. interface Métrique
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
255.255.255.255 255.255.255.255 255.255.255.255 2 1
255.255.255.255 255.255.255.255 255.255.255.255 3 1
===========================================================================
Itinéraires persistants :
Aucun
Messages postés
29130
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 janvier 2020
6744
Le pc "maman" est bien configuré mais pas le pc" pbell". Commence par t'assurer que les deux pcs peuvent dialoguer en mode adhoc, sinon il faudra peut être passer via la freebox.

En particulier je ne sais pas si elle fait routeur wifi, comme une livebox, mais si c'est le cas c'est la solution la plus simple (par la même occasion le pc "pbell" pourra se connecter au Net.

En supposant que tes cartes réseaux puissent fonctionner en mode ad hoc, il faut leur donner une adresse ip, toute les deux commençant par 192.168.1., via le panneau de configuration, connexions réseaux :

pc maman :
ip 192.168.1.2
masque 255.255.255.0

pc pbell :
ip 192.168.1.3
masque 255.255.255.0

Active les deux cartes wifi avec ces paramètres en modeadhoc et ça devrait marcher.

Bonne chance
Lavelle
Messages postés
4
Date d'inscription
mardi 13 décembre 2005
Statut
Membre
Dernière intervention
16 décembre 2005

merci pour ta réponse, j'ai déja configuré les deux PC avec des adresses Ip 192.168.0.1 pour Maman et 192.168.0.2 pour le pc PBELL, avec le masque 255.255.255.0
le pb est que le mode adhok ne fonctionne pas correctement. suivant les différentes config que j'ai pu faire, un coup ils se voient (pendant peu de temps, une dizaine de secondes), ou il ne se connectent pas au réseau Maman10 , alors que le réseau Maman 10 est bien actif quand je lance la recherche de réseau sur chaque PC.
il faudra peut-être que j'investisse dans une option WiFi pour la Freebox?
ce qui me gonfle, c'est qu'il semble que certains utilisateurs du forum sembent avoir réussis à connecter 2 pc sous Xp entres eux en mode adhoc, mais malheureusement, ils ne donnent pas de détails!
Messages postés
29130
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 janvier 2020
6744
En fait ce qui est important c'est les routes. Il faut que tu aies une route du type 192.168.1.0 255.255.255.0 sur les deux pcs, associés à l'interface wifi. Pour regarder les routes, un petit route print comme expliqué plus haut.

Tant que tu n'auras pas cette route, c'est que le réseau (interface, route) est mal configuré. Si tu as les routes que tu arrives à pinguer l'autre pc, c'est bon.

Pour ce qui est de "voir" un autre pc, en général le système windowsien amrche assez mal, même en ethernet, c'est dire. C'est pour ça que moi j'ai plutôt tendance à utiliser des serveurs et des clients ftp, là au moins on a pas de surprise. Et en plus si un pc (ou les deux) sont sous linux, la solution reste fonctionnelle ;-)
Lavelle
Messages postés
4
Date d'inscription
mardi 13 décembre 2005
Statut
Membre
Dernière intervention
16 décembre 2005

merci beaucoup pour ton aide!
j'ai bien noté tes recommandations!
Pour l'heure, je viens de commander la carte WiFi de la Freebox qui me permettra d'utilser la boîte en routeur et sera transformé en Point d'accès. je pense que ce sera plus facile à gérer.
Salut,
j'ai pratiquement le même probleme, en effet je viens de me procurer un PC portable où ya une carte wifi intergrée, donc j'ai acheté un adaptateur USB wifi pour pouvoir mettre en place un réseau sans fil ad hoc entre les deux PC et biensur pour apres partager la connexion internet du PC de bureau qui est avec un modem ADSL Speedtouch USB. en faite j'ai essayé de configuré le réseau et les deux PC affichent qu'ils sont bien connectés a ce réseau mais on peu meme ils peuvent meme pas se "pinger" entre eux.
Si quelqu'un pourrait m'aider... SVP
merci d'avance
Messages postés
29130
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
18 janvier 2020
6744
Il faut vérifier que tes deux cartes wifi sont toutes les deux en mod ad hoc, et que tes pare feu / antivirus ne bloquent pas les pings. Il faut naturellement deux ips différentes et que tu parviennent a les connecter entre elles.

Ceci fait, il faudra créer un pont réseau pour que les paquets provenant de ta carte wifi soient redirigés vers le modem.

Sinon, encore plus simple, tu achète un routeur wifi et tu t'y connectes en mode managed (infrastructure) avec tes deux cartes wifi.
Driss35
Messages postés
18
Date d'inscription
jeudi 8 décembre 2005
Statut
Membre
Dernière intervention
22 août 2015

j'ai trouvé enfin le pb pr le ping c'etai le parfeu en effet sinon la je cherche a partager ma connexion entre les 2 ordinateurs sans avoir besoin d'un routeur si possible. si il ya qlq1 qui pourrai m'aider ou qui connai des logiciel qui font ce travail je serai reconaissant. je chercherai sur le net pour ma par lol .
a plus.
ce qui est bien c'est de nous dire comment tu as fait pour que ça marche merci
kaumune
Messages postés
18638
Date d'inscription
lundi 26 novembre 2007
Statut
Contributeur
Dernière intervention
21 janvier 2020
2968
Slt

8 ans après, peu de chances qu'il suive encore le sujet ..;-)
Messages postés
18
Date d'inscription
jeudi 8 décembre 2005
Statut
Membre
Dernière intervention
22 août 2015

enfin j'ai réussi a partager la connexion entre les deux ordi ca marche nikel enfin ! la ce que je constate que le réseau sans fil entre les deux se connecte avec les norme 802.11b au lieu de 802.11g alors que les deux supporte cette norme jvoudrai savoir comment les faire connecter avec la norme g au lieu de b merci d'avance =)
Messages postés
18
Date d'inscription
jeudi 8 décembre 2005
Statut
Membre
Dernière intervention
22 août 2015

c bon j'ai trouvé le pb le mode g étai desactivé dans l'daptateur USB wifi et la ca marche tout beigne !